0

I have a strange problem with a nfs mounted drive. It's a zfs pool shared via nfs, both server and client use Linux Mint 18.1.

What happens is that when I copy a larger file to the server, the progress bar hits 100 % almost immediately (with some ridiculous speed) and then just hangs before the actual transfer completes. So far I tried two file managers (MATE's default Caja and Double Commander) with the same result.

Interestingly, when I copy in the opposite direction (from server to client) it all works as expected.

I suspect this could be the property of the NFS protocol itself - how it reports on the amount of transferred data or something. I'm not sure.

I have two questions:

  1. Is this normal or is it a bug, possibly?

  2. If not a bug, is there a way to configure it to play nicely with progress bars?

My /etc/exports looks like this:

    /media/data        192.168.2.1/24(rw,sync,no_root_squash,no_subtree_check)

I also tried async, it didn't make any difference.

  • 1
    You are dealing with buffering in RAM ; the client just copies everything to a buffer, and I bet it waits until it is notified by the server of the success of the operation. I clearly know the buffer detail, though I do not remember the specifics. – Rui F Ribeiro May 25 '17 at 19:05
0

I'm not familiar with either of those file managers. Have you tried a simple copy? ie: timex cp <X> <Y>

Perhaps the file managers are doing a check after the copy? Possibly some kind of checksum/md5 hash check?

Version on NFS in use? zpool on server ok? zpool status -x

  • And I'm not familiar with timex. Did you mean time? Anyway, cp combined with time would only tell me how long it takes to copy the file. I'm interested in seeing the correct percentage of transmitted data while copying. I'm sure it's a simple copy without any checks. It's NFS v4 and the zpool is healthy. – Jan Noha May 25 '17 at 21:38
  • Oops, Solaris hat for timex cmd. But basically, I was wondering if using the cp command gave you better results, as well as gathering additional data in determining the discrepancies/oddities that you're seeing. Which may also help hint if it's a FS or file manager issue. – sleepyweasel May 31 '17 at 0:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.