I have a Dell-Precision 5510 laptop with Ubuntu 14.04 installed. I left it unused for about a month, and when I tried to turn it on, turn-on button lighted up, stayed this way in about 20 or 30 seconds, and then died. After a few hours, the screen at last lighten up, and after showing the Dell logo, it told me : "No Boot Device is found. Press any key to rebooot the machine". I did it, but it went through the same routine back to the same message. I am terrified; any idea what can be done?

  • Sounds like something's wrong with the disk. It has either been corrupted or removed. This issue is not related to Unix, as far as I can tell. Try booting from a live-USB to investigate further.
    – Kusalananda
    May 25, 2017 at 14:37
  • Thanks, Kusalanand. I feel terribly stupid (just a plain user...) -- but I don't know how to do a live-USB...
    – Al Kap
    May 25, 2017 at 14:56
  • Did you change boot mode from UEFI to BIOS or vice-versa? Error is from UEFI/BIOS, not seeing bootable files either in MBR or in ESP - efi system partition. Also can be drive error as posted below.
    – oldfred
    May 25, 2017 at 17:27
  • Sorry, oldfred, I've been away from my comps for about three weeks, and didn't check out your reply. Thanks for your reply. On substance: how I can change boot mode from UEFI to BIOS or vice-versa if I want to check out your idea?
    – Al Kap
    Jun 14, 2017 at 6:11

2 Answers 2


English is not my native language so please be patient.

This sound more like a Hardware problem, than software. My first advice would be remove all Hard Drives, clean the RAM memories and the board too.

Try first to boot again with only one RAM module and keep switching them until the device boot to DELL bios Menu or further. Then you can discard a RAM issue.

The second try would be the Hard Drive, you can create a LiveUSB of linux to search bad sectors (use dd or Gparted) or any problems alike.

  • After that you could try the LiveUSB option, I updated my answer with a link to tutorial.
    – Elber CM
    May 25, 2017 at 15:24

When my comp got to "No Boot Device is found. Press any key to reboot the machine", I tapped the key F2 many times until it open up a page that had a list of various options, and in the top section "General" I clicked at "Boot options" (or something like that). It opened another page, which among other things asked me about which option I want to choose -- just two of them -- "Legacy" and "UEFI"; it showed that the current one is "Legacy". Following a hint offered by @oldfred (see in "Comments") who mentioned the term "UEFI" (beats me if I know what is that:), I decided to click at it instead of "Legacy", and it worked! When I returned to a previous page (by clicking "Exit"), it showed me a starting Ubuntu page! The comp is still telling me that there is an error in system programming, but otherwise I am happy to have at least my data back....

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.