3

My computer seems to have only one of the two processor cores operating.

inxi
CPU~Single core Intel Core2 Duo T6400 (-UP-) speed~2000 MHz (max) Kernel~4.4.0-53-generic x86_64 Up~2:40 Mem~1180.8/3951.5MB HDD~80.0GB(34.1% used) Procs~160 Client~Shell inxi~2.2.35
lscpu
Arquitectura:          x86_64
modo(s) de operación de las CPUs:32-bit, 64-bit
Orden de bytes:        Little Endian
CPU(s):                1
On-line CPU(s) list:   0
Hilo(s) de procesamiento por núcleo:1
Núcleo(s) por «socket»:1
Socket(s):             1
Modo(s) NUMA:          1
ID de fabricante:      GenuineIntel
Familia de CPU:        6
Modelo:                23
Model name:            Intel(R) Core(TM)2 Duo CPU     T6400  @ 2.00GHz
Revisión:             10
CPU MHz:               2000.000
CPU max MHz:           2000,0000
CPU min MHz:           1200,0000
BogoMIPS:              4000.41
Caché L1d:            32K
Caché L1i:            32K
Caché L2:             2048K
NUMA node0 CPU(s):     0
Flags:                 fpu vme de pse tsc msr pae mce cx8 sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm constant_tsc arch_perfmon pebs bts rep_good nopl aperfmperf pni dtes64 monitor ds_cpl est tm2 ssse3 cx16 xtpr pdcm sse4_1 xsave lahf_lm dtherm

My computer is an ASUS F50SL laptop, which came with Windows Vista factory installed. And the BIOS lacks options to enable / disable advanced ACPI options, such as Acpi apic or Acpi 2.0... Options, that you can find in desktop BIOS versions; for example. This is the information

inxi -F
System:    Host: x-PC1 Kernel: 4.4.0-53-generic x86_64 (64 bit) Desktop: MATE 1.16.1
           Distro: Linux Mint 18.1 Serena
Machine:   System: ASUSTeK product: F50SL v: 1.0
           Mobo: PEGATRON model: F50SL v: 1.0 Bios: American Megatrends v: 209 date: 11/12/2009
CPU:       Single core Intel Core2 Duo T6400 (-UP-) cache: 2048 KB speed: 2000 MHz (max)
Graphics:  Card: Advanced Micro Devices [AMD/ATI] RV710/M92 [Mobility Radeon HD 4530/4570/545v]
           Display Server: X.Org 1.18.4 drivers: fbdev,ati (unloaded: vesa,radeon) Resolution: 1024x768@76.00hz
           GLX Renderer: Gallium 0.4 on llvmpipe (LLVM 3.8, 128 bits) GLX Version: 3.0 Mesa 11.2.0
Audio:     Card-1 Advanced Micro Devices [AMD/ATI] RV710/730 HDMI Audio [Radeon HD 4000 series]
           driver: snd_hda_intel
           Card-2 Silicon Integrated Systems [SiS] Azalia Audio Controller driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.4.0-53-generic
Network:   Card-1: Silicon Integrated Systems [SiS] 191 Gigabit Ethernet Adapter driver: sis190
           IF: enp0s4 state: up speed: 100 Mbps duplex: full mac: e0:cb:4e:69:13:c4
           Card-2: Qualcomm Atheros AR928X Wireless Network Adapter (PCI-Express) driver: ath9k
           IF: wlp2s0 state: down mac: 00:22:43:6f:d3:08
Drives:    HDD Total Size: 80.0GB (34.1% used) ID-1: /dev/sda model: INTEL_SSDSA2M080 size: 80.0GB
Partition: ID-1: / size: 32G used: 8.7G (30%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 8.59GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 69.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 160 Uptime: 2:54 Memory: 1256.8/3951.5MB Client: Shell (bash) inxi: 2.2.35 

So; to be able to boot the computer correctly I am forced to make certain modifications to the grub file in the path: etc/default/grub I made the following necessary changes:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset nolapic acpi_osi=\"Windows 2006\""

And after this I updated the grub with sudo update-grub

Since apic is linked to the processor management and to be able to boot I have to disable it by manually entering changes to the GRUB file. I think those changes I have set, have to do with the deactivation of one of the CPU cores.

What can I do to make both cores of my processor work instead of just one?

  • It is like your kernel isn't compiled with SMP support - you should see SMP in the output of uname -a or in your inxi output. What kernel packages are installed? dpkg -l | grep linux-image – ivanivan Oct 1 '17 at 2:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.