I have following problem, with my Mint 18.1 Cinnamon, when I plug a USB flash drive, or my phone in USB port, my desktop dies immediatly: the backgrond picture disapears, it's all black, and I can't click on anything. I have to go in my ~home/Desktop my self. Everything else keeps working: the Menu button, Firefox etc.. and all the programs are functional. I need to restart system in order to make Desktop fonction again.

Any idea how I could fix this? It never happened before, but I must have installed some "Updates" in Software manager which doesn't work well..

  • Then, do not plug any USB device on you computer to avoid the error....Just kidding. It is the same port that have this error? Can you post the result of the dmesg command right after the screen goes black. You could enable ssh on your machine, and from other computer capture the contents of dmesg
    – user34720
    May 25, 2017 at 10:49
  • Yes, whatever the port is, the result is the same. dmesg gives a whole bunch of lines, which I dont understand. Kdiff tells me there are like 100 lines of difference before / after I plug in. However, the problem doesn't happen when it's a usb-mouse, so I might think the problem arises when it auto-mounts the device (I mean, when there is an external storage, like phone or usb flash drive)..
    – dgan
    May 25, 2017 at 15:40
  • We will need you to probe and post your dmesg. We cannot help you without taking a look at the logfiles...
    – user34720
    May 25, 2017 at 16:22

1 Answer 1


Okey the answer is following: Mint 18.1 has 2 file managers, Nemo and Nautilus. When a device is plugged in, Mint uses Nautilus for navigation. Nautilus is completly buggy on my computer. In order to stop crashing my Desktop with Nautilus, I set Nemo as default file manager

xdg-mime default nemo.desktop inode/directory application/x-gnome-saved-search

I also added "inode/directory=nemo.desktop" in ~/.local/share/applications/mimeapps.list

If for whatever reason you don't want to use Nemo, you can simply disable auto-opening with Nautilus after a device is mount as specified here: https://askubuntu.com/questions/191527/disable-auto-opening-nautilus-window-after-auto-mount

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .