5

I have VirtualBox (VB) 5.1.22 installed on Fedora 25 and I installed Windows 8.1 Pro within VB.

I belong to group vboxusers:

$ id
uid=1010(fuji) gid=1025(staff) groups=1025(staff),1030(vboxusers)

and I still cannot see the USB devices that should be listed in the "Devices/USB" menu: No usb devices connected

Selecting USB 2.0 Controller does not fix the problem. Pluging my USB 3.0 key in a USB 2.0 slot does not fix the problem either.

Am I missing something?

5
  • Did you ever solve this? I also have this problem: I am a member of vboxusers and I can see the devices being created under /dev/vboxusb/... with the correct group applied. I can even run the "vboxmanage list usbhost" and see all my USB devices - I just can't see them in the GUI, or from inside the guest VM :-(
    – karora
    Oct 26, 2017 at 14:05
  • No, I haven't solved the problem yet. I'll try again monday with VB 5.2.0.
    – Fuji San
    Oct 27, 2017 at 20:35
  • I've been seeing this problem with VirtualBox 5.2.1, so I doubt that's going to solve the issue. For my own purposes I've switched to using KVM, which has no problem handling this, but with that one I haven't figured out how to make KVM handle unplugging/plugging my USB device without restarting the VM.
    – karora
    Oct 28, 2017 at 15:12
  • 1
    @karora I solved it finally. The vboxusers group id displayed by command id (here 1030) was not the same as the one in the file /etc/group. That group id 1030 was set up in FreeIpa and given to all users. I removed it from FreeIpa and did a usermod -G staff,vboxusers fuji to add user fuji to group vboxusers that is in file /etc/group.
    – Fuji San
    Jan 12, 2018 at 9:39
  • Refer to this: stackoverflow.com/questions/20021300
    – Eric
    Jun 10, 2018 at 13:33

2 Answers 2

4

Edit your virtual machine -> usb -> Click on the little USB logo with the Green plus signal. Add the usb device you want to show to your guest OS. Be happy. :)

If you see them in the list, but they fail in installing driver, check to see you have USB2.0 enabled in virtualbox settings. USB1.0 is set by default and will not be able to install USB 2.0 drivers. The program may prompt you to install an extension pack for this. Once USB 2.0 (or 3.0 if you have a USB3.0) is enabled, the USB should attach and proper drivers installed.

If that does not work, you will probably need to disable that device inside host and enable it in guest. There is an awesome and complete tutorial at Ask Ubuntu, related to this question:

I know that i should not link external how-tos here, but this is a matter of not repeating something that other people have already answered inside SE sites.

Another detail is that, for Windows guests the following limitations apply:

  • Windows 7 needs an additional driver for USB 3.0 support.
  • Windows 10 does not accept an NTFS formatted USB pen drive.
11
  • 2
    There is nothing in the "USB with the Green plus signal". So I cannot enable anything in the guest. And I made sure the USB key was not mounted in the host.
    – Fuji San
    May 29, 2017 at 13:08
  • And have you followed all the tips that are on the Ask Ubuntu reference link?
    – user34720
    May 29, 2017 at 13:11
  • I'm under Fedora 25 and I enabled support for USB 3.0 . My key is USB 3.0 . The mouse tooltip says "No supported device connected to the host pc."
    – Fuji San
    May 29, 2017 at 13:15
  • The extension pack for 5.1.22 is installed. I'm in group vboxusers. I have support for USB 3.0 enabled. And I do not see any key listed in the devices/USB menu.
    – Fuji San
    May 29, 2017 at 13:25
  • 1
    Does "vboxmanage list usbhost" list your USB devices?
    – karora
    Oct 28, 2017 at 15:13
0

You might have to run modprobe -r usb_storage to get the host to give up the drive.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .