1

I need to run 2 diff cmd in ad-hoc mode in ansible ?? is it possible

1] hostname

2] df -h

# ansible example -s -a "hostname && df -h"

Error

```[root@ansi1 ansible]# ansible example -s -a "hostname && df -h"
ansi2.example.com | FAILED | rc=4 >>
Usage: hostname [-v] {hostname|-F file}      set hostname (from file)
       domainname [-v] {nisdomain|-F file}   set NIS domainname (from file)
       hostname [-v] [-d|-f|-s|-a|-i|-y|-A|-I]  display formatted name
       hostname [-v]                         display hostname

       hostname -V|--version|-h|--help       print info and exit

    dnsdomainname=hostname -d, {yp,nis,}domainname=hostname -y

    -s, --short           short host name
    -a, --alias           alias names
    -i, --ip-address      addresses for the hostname
    -I, --all-ip-addresses all addresses for the host
    -f, --fqdn, --long    long host name (FQDN)
    -A, --all-fqdns        all long host names (FQDNs)
    -d, --domain          DNS domain name
    -y, --yp, --nis       NIS/YP domainname
    -F, --file            read hostname or NIS domainname from given file

   This command can read or set the hostname or the NIS domainname. You can
   also read the DNS domain or the FQDN (fully qualified domain name).
   Unless you are using bind or NIS for host lookups you can change the
   FQDN (Fully Qualified Domain Name) and the DNS domain name (which is
   part of the FQDN) in the /etc/hosts file.
```
2

Found my mistake ,,,silly one

[root@ansi1 ansible]# ansible example -s -m shell -a "hostname && df -h"
ansi2.example.com | SUCCESS | rc=0 >>
ansi2.example.com
Filesystem            Size  Used Avail Use% Mounted on
/dev/mapper/vg_ansible2-lv_root
                      6.5G  980M  5.2G  16% /
tmpfs                 939M     0  939M   0% /dev/shm
/dev/sda1             477M   54M  398M  12% /boot
  • 2
    Correct. Ansible uses the command module by default. For && to work, you need to use the shell module. – GMaster May 25 '17 at 2:42
0

It seems ansible does not use shell in order to run your command. However you obviously use shell syntax in your custom command: &&. So one option for you is to directly tell ansible to use shell:

$ ansible localhost -s -a "bash -c 'hostname && df -h'"
  • When you explicitly specify -m shell it uses shell. All shell syntax are supported including &&,||, etc. I think you are confusing with the command module in Ansible. When you don't specify anything, Ansible uses the command module and &&,||, etc are not recognised. – GMaster May 25 '17 at 2:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.