1

I'm using Fedora 25 and my screen always blanks after 10 minutes of inactivity. I tried disabling it since it's very annoying when watching videos, but I didn't have any luck so far. These are the steps i tried, but none of them worked:

  • Disabled screen blanking in Settings->Power
  • Disabled X screen blanking with

    xset -dpms
    xset s off
    xset dpms 0 0 0 && xset s noblank && xset s off
    
  • Tried running GNOME under Wayland
  • Tried setting the following gsettings
    • org.gnome.desktop.screensaver.idle-activation-enabled to false
    • org.gnome.desktop.screensaver.lock-delay to 0
    • org.gnome.desktop.session.idle-delay to 0 and 10800
    • org.gnome.settings-daemon.plugins.power.sleep-display-ac to 0
    • org.gnome.settings-daemon.plugins.power.sleep-display-battery to 0
    • org.gnome.settings-daemon.plugins.power.idle-dim to false

Nothing worked, my screen still goes blank after 10 minutes. Any settings I could have overlooked?

  • Did you turn screen lock off in privacy settings? It might be interfering. Else you could get the caffeine extension and use that. – Mioriin May 23 '17 at 18:18
  • Sounds almost like a visual bell, is it possible to have that in a graphical environment? – Pythonic May 23 '17 at 18:24
  • Neither turning off screen lock nor caffeine made any difference :/ – Metalfreak May 23 '17 at 20:00
1

I found the problem, XFCE installed xscreensaver as a dependency and it was automatically started alongside GNOME for some reason

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.