I have some iei panels pc that keep, after a minute or so, blacking the screen. The thing is that I want the screensaver to launch but I don't want it to black the screen.

X is launched by nodm, and X is configured with dpms and screen saver disabled so :

xxx@xxx-001:~$ xset -q
Keyboard Control:
  auto repeat:  on    key click percent:  0    LED mask:  00000000
  XKB indicators:
    00: Caps Lock:   off    01: Num Lock:    off    02: Scroll Lock: off
    03: Compose:     off    04: Kana:        off    05: Sleep:       off
    06: Suspend:     off    07: Mute:        off    08: Misc:        off
    09: Mail:        off    10: Charging:    off    11: Shift Lock:  off
    12: Group 2:     off    13: Mouse Keys:  off
  auto repeat delay:  660    repeat rate:  25
  auto repeating keys:  00ffffffdffffbbf
  bell percent:  50    bell pitch:  400    bell duration:  100
Pointer Control:
  acceleration:  2/1    threshold:  4
Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  0    cycle:  0
  default colormap:  0x20    BlackPixel:  0    WhitePixel:  16777215
Font Path:
DPMS (Energy Star):
  Standby: 7200    Suspend: 7200    Off: 14400
  DPMS is Disabled

I also disabled consoleblank through grub's kernel option:

xxx@xxx-001:~$ cat /sys/module/kernel/parameters/consoleblank

I tried a few other things around setterm/issue, even kms and I also tried a few other kernel

But nothing seems to work, it keeps blanking.

Does anyone see a lead I should look into?

P.S.: I'm aware of how to stop the screen from blanking / blacking out? and a few other ones

Edit : My problem is coming from xscreensaver, if I disable it the monitor behave as expected. But I use the same .xscreensaver on other hosts and they behave properly, they use the same kernel and same version of X11

My .xscreensaver :

# XScreenSaver Preferences File
# Written by xscreensaver-demo 5.15 for ineo on Tue Oct 15 17:26:18 2013.
# http://www.jwz.org/xscreensaver/

timeout:        0:01:00
cycle:          0:10:00
lock:           False
lockTimeout:    0:00:00
passwdTimeout:  0:00:30
visualID:       default
installColormap:    True
verbose:        False
timestamp:      True
splash:         True
splashDuration: 0:00:05
demoCommand:    xscreensaver-demo
prefsCommand:   xscreensaver-demo -prefs
nice:           10
memoryLimit:    0
fade:           False
unfade:         True
fadeSeconds:    0:00:03
fadeTicks:      20
captureStderr:  True
dpmsEnabled:    False
dpmsQuickOff:   False
dpmsStandby:    2:00:00
dpmsSuspend:    2:00:00
dpmsOff:        4:00:00
grabDesktopImages:  False
grabVideoFrames:    False
chooseRandomImages: False
imageDirectory: /home/xxxx/images

mode:           one
selected:       0

textMode:       url
textLiteral:    XScreenSaver
textProgram:    fortune
textURL:        http://fridge.ubuntu.com/node/feed

programs: bash /home/xxxx/screensaver-launcher.sh -root

pointerPollTime:    0:00:05
pointerHysteresis:  10
initialDelay:   0:00:00
procInterrupts: True
xinputExtensionDev: False
overlayStderr:  True

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.