0

My system is Xubuntu 16.04 LTS. Recently a new fiber router has been installed, but even though I'm connected to it via WiFi, I can neither browse nor use any command that requires an internet connection. The odd thing is that other computers connected to this same point and my own cellphone can browse normally.

I am using DHCP:

enter image description here

The command netstat -rn shows the following:

enter image description here

closed as unclear what you're asking by jasonwryan, phk, Anthon, DarkHeart, Kusalananda May 23 '17 at 19:38

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • You are talking about a WLAN access point that is also your router? And other devices get routed over this access point, while your computer works with other access points and only the combination of the new AP and your computer doesn't work? Everything right so far? Now step by step: do you use DHCP? Do you receive an IP at all? – Philippos May 23 '17 at 5:51
  • Yes, we all connect but only I cannot browser anything. Yes, it is all DHCP and I also receive an IP by executing ip route show | grep -i 'default via'| awk '{print $3 }' – gamofe May 23 '17 at 5:57
  • Okay, I suggest to put this information in the question (someone already downvoted). And also include the answer on netstat -rn – Philippos May 23 '17 at 6:02
  • Right, I've added it to the question. – gamofe May 23 '17 at 6:27
  • Check if IPv6 is in use (-6) and not shown here. Where does the APIPA(169.254.*.*) address come from? Can you ping the gateway? Can you ping google-dns(8.8.8.8)? What is you nameserver? nslookup bbc.co.uk – sebastianwagner May 23 '17 at 6:40
4

As mentioned in the comments you are able to ping 8.8.8.8 but can't ping google.com. The problem resides in your DNS-settings. Some of your four DNS won't resolve addresses correctly. You might try an other DNS-server e.g. by entering 8.8.4.4, 8.8.8.8 or 141.1.1.1 in your Network-Manager in the IPv4-pane.

Prior to this you might check if this works out by trying: host nature.com 141.1.1.1. For me the result was something like 195.128.8.101.

  • Oh, you're Filipino? I am living in the Philippines. – gamofe May 23 '17 at 7:44
  • @mfgabriel92 Rarely Linux/FreeBSD seem to not like the DNS server/proxy provided by the cable modem while the other devices seem happy with it; I have seen the behaviour yet not had the time to debug it yet. btw, magandang umaga. The same is happening at my father´s house with my Lenovo, however I do visit rarely. – Rui F Ribeiro May 23 '17 at 7:47
  • 1
    @mfgabriel92 I do not live there, but I have a Filipina wife. I know enough to recognize the PLDT name. They are (in)famous. I would change the default SSID, and the default password, they can be easily cracked, the algorithm is supposed to be known. However, if at the office, the filipinos are not able to say no when neighbours ask for the password, so I do not know if it is worth wasting the time in that case... – Rui F Ribeiro May 23 '17 at 8:09
  • 1
    @mfgabriel92 If you are not situated in EU/USA, there are better suited DNS-servers for you: bestdns.org/for/ph this should speed up resolution. – sebastianwagner May 23 '17 at 8:18
  • 1
    @sebastianwagner There are local CDN google mirrors near in Sidney; beware of the quality and security implications of using random DNS servers. myphilippinelife.com/globe-internet-dns-problems – Rui F Ribeiro May 23 '17 at 8:21

Not the answer you're looking for? Browse other questions tagged or ask your own question.