0

I'm installing Kivy on my laptop running GalliumOS and when I do

pip install kivy

It gives me all of this stuff. I'm new to Linux and Python so I have no idea what any of this really means.

Collecting kivy
Using cached Kivy-1.10.0.tar.gz
Complete output from command python setup.py egg_info:
Using distutils

Detected Cython version 0.23.4
Using this graphics system: OpenGL
WARNING: A problem occurred while running pkg-config --libs --cflags gstreamer-1.0 (code 1)

Package gstreamer-1.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `gstreamer-1.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'gstreamer-1.0' found


WARNING: A problem occurred while running pkg-config --libs --cflags sdl2 SDL2_ttf SDL2_image SDL2_mixer (code 1)

Package sdl2 was not found in the pkg-config search path.
Perhaps you should add the directory containing `sdl2.pc'
to the PKG_CONFIG_PATH environment variable
No package 'sdl2' found
Package SDL2_ttf was not found in the pkg-config search path.
Perhaps you should add the directory containing `SDL2_ttf.pc'
to the PKG_CONFIG_PATH environment variable
No package 'SDL2_ttf' found
Package SDL2_image was not found in the pkg-config search path.
Perhaps you should add the directory containing `SDL2_image.pc'
to the PKG_CONFIG_PATH environment variable
No package 'SDL2_image' found
Package SDL2_mixer was not found in the pkg-config search path.
Perhaps you should add the directory containing `SDL2_mixer.pc'
to the PKG_CONFIG_PATH environment variable
No package 'SDL2_mixer' found


 Traceback (most recent call last):
   File "<string>", line 1, in <module>
   File "/tmp/pip-build-4Vxs2J/kivy/setup.py", line 934, in <module>
     version=get_version(),
   File "/tmp/pip-build-4Vxs2J/kivy/setup.py", line 47, in get_version
     ['git', 'rev-parse', 'HEAD']
   File "/usr/lib/python2.7/subprocess.py", line 567, in check_output
     process = Popen(stdout=PIPE, *popenargs, **kwargs)
   File "/usr/lib/python2.7/subprocess.py", line 711, in __init__
     errread, errwrite)
   File "/usr/lib/python2.7/subprocess.py", line 1343, in _execute_child
     raise child_exception
 OSError: [Errno 2] No such file or directory

----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-4Vxs2J/kivy/

All I'm trying to do is install Kivy. I do have pip installed because I've used pygame a bit in the past.

Is there any easy way to fix this? I'm not too keen on digging into the files but I will if I have to so that this will work.

I have both Python 2.7 and 3.5 installed.

0

No package {gstreamer-1.0.pc, sdl2.pc, SDL2_ttf.pc, SDL2_image.pc, SDL2_mixer.pc}

I.e. /usr/lib/pkgconfig/[files].pc .

sudo apt-get install apt-file : Then you can use apt-file search [file.pc] to list the [packages]-dev required for Kivy. ( Probably like libgstreamer0.10-dev, libsdl2-dev, etc.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.