2

I have a server where multiple people have an user account and they rsync the same folder. To enable that, I've put all users into the same group and when rsyncing, they use --chmod=g+w.

File are correctly accessible by each user in the group, but anyone who isn't the guy who created the folders will fail to complete the rsync, because they cannot set permissions on the folder because they aren't the owner.

How would I tell rsync to not chmod things it has no ownership for?

  • You can restrict the chmod to files with --chmod=Fg+w – meuh May 22 '17 at 13:05
  • 1
    @meuh But I need to have directories with g+w too, when they are created. – U Mad May 22 '17 at 18:14
1

Use the --no-perms option to prevent changing the permissions of existing destination files. The --chmod permissions will only be used for new files/folders that are being created.

Assuming all the existing files amd folders have already been created with correct group permissions, it should only be necessary to set the permissions for new ones, so this should be adequate.

However, instead of adding permissions with --chmod=g+w, you should specify the complete permissions set, e.g. --chmod=ug=rwX,o=rX, because --no-perms tells it not to copy the original permissions for files being copied.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.