1

I've got a MSI laptop with a Windows 8.1/Debian 8 dual-boot installation. Recently, my 500GB hard drive (which is 3,5 years old) has begun to show signs of weakness, so i've replaced it with a 500GB SSD. I used Clonezilla to clone the whole drive to the SSD, via an external HDD (i created an image of the drive on the external HDD, then extracted it on the SSD).

The cloning was successful, but now the laptop boots directly on Windows. Before that I had a Grub screen where I could choose between Debian and Windows Boot Manager.

The option to boot on Debian has disappeared from the UEFI boot menu. I managed to manually boot on Debian with a Grub terminal using a Debian installation USB drive. I tried doing update-grub and then grub-install, but I got the following error:

Installing for x86_64-efi platform.
efibootmgr: Could not set variable Boot0000: No such file or directory
efibootmgr: Could not prepare boot variable: No such file or directory
Installation finished. No error reported.

Did I miss something ?

  • 1
    Ok that's fixed, I found a solution here: I used the command bcdedit /set {bootmgr} path \EFI\debian\grubx64.efi in a Windows admin command prompt, apparently it forces Windows to use Debian's bootloader. I don't really get what was the problem in the first place but now it works ! – Kaike May 22 '17 at 12:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.