I'm currently trying to able the Trash feature in a NTFS partition mounted automatically on boot. To do that I'm using the permissions option in my fstab:

UUID=1CACB8ABACB88136 /media/FILES ntfs defaults,permissions,relatime 0 0

then I changed the permissions:

sudo chown :users -R /media/FILES/
sudo chmod g+rwx -R /media/FILES/

It works great except I continue to not have the trash feature. I can read, write, execute being member of the users group but I cannot use the Trash feature in Nautilus, only permanent delete. Any thoughts ?


2 Answers 2


Hey guys I've found the solution, removing my old .Trash folder that was there but wasn't working:

sudo rm -rf /media/FILES/.Trash-1000

worked like a charm, I'm now able to move to Trash from nautilus. And I'm pretty sure that If I create a new user he will be able to have its own trash too.

  • I don't have this dir and thw Linux's Trash for an NTFS partition doesn't work since ages... Do you have any clue on this? Thanks.
    – dentex
    Dec 15, 2018 at 17:40
  • I had this folder, and deleted it, but no change
    – rubo77
    Aug 1, 2020 at 14:52

There needs to be a folder called the .Trash-{userid} in the root of the mounted partition, to enable the Trash functionality inside nautilus.

Permissions of g+w is only needed to create the folder. I wouldn't suggest giving all users from that group write access unless otherwise needed.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .