0

I have a yiynova mvp22U+rh digitizer (monitor tablet), I used it last a couple of months back, it worked fine on both linux and windows, I don't remember how linux used to detect it but windows detects it as a 'Generic non-pnp monitor' and shows all kinds of resolutions the monitor can't even use (but it also has the 1920x1080 resolution I want to use).

Meanwhile over at Linux, it is now being read as a CRT for some reason (on a DVI port...) with a max resolution of 1024x768.

I don't like that it's being read as a crt, and wonder if that has any effects on the display (e.g. are there any different outputs sent to CRTs than LCD's and should i try to fix that?) but mostly, I just want my 1920x1080 resolution back because I can't work like this. I was quite surprised when I encountered this issue cus last time I tried to use the monitor it worked just fine on linux. It may have broken in an update.

Update: I've tried to use xrandr's newmode/addmode functions as described over here but it fails with Error: BadMatch...

I remember having a similar issue before once with an actual CRT having wrong resolution detected, and that time it was a brutally difficult task to fix it, I had to fabricate some file (EDID) that specifies the monitor type to the gpu. I hope I don't have to do that again...

  • 1
    I think this means that the monitor isn't sending EDID information, or that it's sending it in a form that the OS doesn't understand (so it could be an OS bug, but that's unlikely if you have the problem both under Windows and Linux). It could be a defect in the monitor, which would be hard to fix. It could also be a problem with the graphics card, have you changed it? Can you try the monitor with another computer? Also try replacing the cable, cables can get damaged sometimes and they're relatively cheap to replace. – Gilles May 20 '17 at 13:43
  • The cable is embedded in the monitor so I can't do that :/ I just tried using the EDID from my other monitor and this worked to get the correct resolution but now my stylus is all weird and my former calibration settings aren't working (so it might not be a working solution) – Cestarian May 20 '17 at 14:00
  • I guess using a custom EDID is a valid solution to the resolution problem but there is the stylus issue, I have made a separate question for that here unix.stackexchange.com/questions/366266/… Right now I'm trying to get the EDID for my display (I asked yiynova support and stuff) which might solve my problem. – Cestarian May 20 '17 at 17:35
2

The best solution to this problem is to try a different cable, in most cases where EDID data is not transmitted the problem will be with the cable.

This is most definitely the case for me, however my glaring issue is that the cable is embedded into my display and cannot be switched out (not without a couple of days work to end up with some duct taped hackjob anyways)

So my solution to the issue was to use a custom EDID file. There are EDID generators available around the net to create a custom file, you can also do what I did, copy the EDID data from another monitor to a file as described here assuming you are using nvidia's proprietary drivers as I happened to be. There are many other ways to achieve this (Refer to this question)

As for applying the EDID, this is how I did it (may only work for Nvidia graphics cards) with a xorg.conf file

Section "Screen"
...
Option         "CustomEDID" "GPUID.MONITORID:/path/to/edid.txt" 
...
EndSection

(Fun fact: On windows for nvidia only Quadro and NVS cards can do this, but I have a GTX and it worked fine on Linux)

Since I am working with a digitizer however, the incorrect EDID file messes up my stylus calibrations to quite a serious degree but that was beyond the scope of my original question.

  • Oh yeah I should also probably point this out, on Windows I managed to solve the issue by using Nvidia's drivers to create a custom resolution for 1920x1080 for my monitor. Furthermore, it works completely fine with the windows yiynova tablet drivers without a correct EDID. – Cestarian Aug 9 '17 at 5:05
1

My sister had a similar issue with her Yiynova MSP19U+. It has a VGA connection instead of DVI, but every now and then Windows 7 would be unable to determine the model of the monitor and not list the native resolution (1440x900.) Turned out it was a wire issue in the VGA cable that's built into the tablet monitor. I was able to replace part of the wiring that was broken and now it properly reports its EDID again.

I wrote an article about the issue here: https://extraordinaryben.wordpress.com/2017/08/08/yiynova-msp19u-vga-pinout-diagram/ (And yes, the section I repaired is now wrapped up in electrical tape... Haha! At least it works perfectly again.)

Since yours has a DVI connection, I'm thinking you might have a wire issue with pins 6 and 7 in the following diagram. DVI pinout diagram

If you don't want to try repairing the cable, (soldering skills are required,) you can probably order a replacement cable from The Panda City, the official US distributor of Yiynova products.

  • Wow way to dive straight down to the hardware, it has a DVI-I dual link tho... Which is what the diagram displays. There is no replacement cable because it is embedded into the display, and I don't think they ship to iceland, but the problem is finding the break, how on earth do I find the break? wiggling the cables won't solve it, since no matter what I do the EDID seems to be dead and I don't wanna risk breaking more wires by wiggling it around. But thanks for your input, this is fairly cool. I have a soldering iron and some tin so I could probably do this if I found the break. – Cestarian Aug 9 '17 at 5:03
  • I wasn't able to add the link to The Panda City's repair page because of the 1 link limit until I had over 10 rep points. thepandacity.com/RepairProcess.aspx I used a multimeter to test for resistance between each pin/connector at the ends of the cable. You would need to open up the monitor to detach the cable. – ExtraordinaryBen Aug 10 '17 at 5:32
  • It may be worth contacting The Panda City to ask if there's a closer distributor near you that can ship a replacement cable. If I ever open up the monitor again I'll remember to take pictures of the connector and how I used the multimeter on it and update the blog article. It's probably safe to assume that any break in the cable would be within the first 2-3 inches of the cable coming out of the monitor, since that's the area that usually experiences the most flexing/bending. – ExtraordinaryBen Aug 10 '17 at 5:42
  • There's a yiynova distributor in the UK I think, anyhow I tried asking panda city and yiynova to just give me a copy of the EDID file which would have theoretically solved my issues and they were pretty reluctant to do so for some reason. – Cestarian Aug 10 '17 at 11:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.