1

Problem: Backlight function keys don't work in KDE, but brightness can be adjusted via "Display Brightness" GUI located in lower right power management icon.

Specs:

  • OS: RHEL 7
  • Window manager: KDE
  • Graphics card: NVIDIA Quadro M1000M
  • Laptop: HP ZBook Studio G3

Solutions attempted and failed:

  • Appending each of the following to grub line: acpi_backlight=vendor acpi_backlight=video acpi_backlight=native acpi_backlight= acpi_backlight=none
  • GRUB_CMDLINE_LINUX_DEFAULT="acpi_osi=" does not make the function buttons work and also has a side effect of not allowing me to change the brightness from the GUI or with changing the value in /sys/class/backlight/. Major fail
1

1 Answer 1

3

Unfortunately I was never able to get the function keys to lower the screen brightness.

Solution:

  • Get nux-desktop for centos 7 repo
  • Install xbacklight (testing xbacklight -10 and xbacklight +10 to validate it was going to work after install).
  • Disabled nux-desktop in yum
  • Setup keyboard shortcuts to lower/increase screen brightness. For some reason the 'Fn' button is not recognized in GNOME when setting up custom shortcut keys, so I had to use Ctrl + F5 and Ctrl + F6.

IMHO, this solution sucks, but it works.

1
  • Fascinating... so it wasn't an issue with the kernel talking to the backlight via ACPI, but something between the keyboard and the kernel.
    – Hydraxan14
    May 19, 2017 at 22:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.