0

I use the below order:

[root@localhost /]# yum install -y mysql mysql-server mysql-devel

to install mysql.

After installed I want to start mysql by:

[root@localhost /]# /etc/init.d/mysqld start
-bash: /etc/init.d/mysqld: there is no file or directory

But you see, I can not start it in this way.

So, I use:

find / -name mysqld 

to find mysqld, I get:

[root@localhost /]# find / -name mysqld 
/usr/libexec/mysqld

So, I use the:

/usr/libexec/mysqld start 

to start mysql, but get the error:

[root@localhost /]# /usr/libexec/mysqld start
2017-05-19 14:28:17 139762539387072 [Warning] option 'open_files_limit': unsigned value 18446744073709551615 adjusted to 4294967295
2017-05-19 14:28:17 139762539387072 [Note] /usr/libexec/mysqld (mysqld 10.1.20-MariaDB) starting as process 82223 ...
2017-05-19 14:28:17 139762539387072 [Warning] Could not increase number of max_open_files to more than 1024 (request: 5035)
2017-05-19 14:28:17 139762539387072 [ERROR] WSREP: rsync SST method requires wsrep_cluster_address to be configured on startup.

And get stuck here.

Someone know how to resolve it?

  • 1
    Which version of CentOS? – dr01 May 19 '17 at 14:51
1

On CentOS 7 you would use the following command.

$ sudo systemctl start mysqld

And if you want mysqld to start automatically on boot you could do

$ sudo systemctl enable mysqld

Edit: Are you sure that you installed MySQL and you are not trying to install MariaDB instead? MariaDB is the default database engine for CentOS I believe. You can check that it actually got installed with

$ rpm -q mysqld

Else, I would recommend following the instructions here

  • Thank you , I install the yum install -y mysql mysql-server mysql-devel, actually is install the mariaDB, alright? – three-blocks May 20 '17 at 1:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.