5

I am trying to install Xenix 386 and/or SCO V Unix in a VM for historical/research/reviving old times/curiosity purposes.

I have already tried to download a couple of media installation images from here.

Tried to boot them several time to install the OS, still without much success; up until now

I already tried with VmWare fusion in OS/X:

  • selecting a 32-bit VM
  • disabling sound cards and USB, to limit the potential interfence of unknown hardware to those OSes
  • giving it just a couple megabytes of RAM
  • Limiting the virtual disk to the known limit of < 250MB
  • testing IDE and SCSI disk emulation.

Both in Xenix and SCO V, the installation diskette (N1) seems to boot, however either the hard disk is not recognised, or the installation hangs with the message:

"Setting up disk environment"

What to do?

  • I think this question may fit retrocomputing.stackexchange.com a bit better. – dirkt May 19 '17 at 15:25
  • @dirkt Not sure indeed. My main worry here is running it in contemporary computing resources, and not emulating anything. – Rui F Ribeiro May 19 '17 at 17:26
3

I encountered a very interested of couple of articles about a bug, post1 and post2 in the installation/disk driver that explained why it did not run in many hardware platforms over the years.

The link, besides explaining the bug, also points out VirtualBox seems to emulate the behaviour and is able to boot those operating systems.

So I installed Virtualbox.

While it did not recognise an emulated SCSI disk, it recognised an emulated IDE disk < 250MB and got indeed into the installation phase.

Setting up installation environment...
%disk     0x1F0-01F7 14         -        type=W0 unit=0 cyls=734 hds=16 secs=31

Welcome to the SCO Unix installation.

Installation media used will be Compact Disc (CD-ROM)

Hit return to continue

...so I grabbed QEMU, and popped N1 in and booted it up. Unfortunately, the system would hang almost immediately after. Some testing revealed that the same issue existed on Bochs. PCjs got a bit further, but kernel panicked nearly immediately. Somewhat surprising to me though was VirtualBox not only booted, it got to the first step of the installer.

The OS is extremely picky about the hardware and BIOS and won’t boot at all in many virtualizers. It also contains an interesting bug in the AT disk driver (called ‘wd1010’ in this XENIX kernel version) which causes the system to hang if the controller, or more likely an IDE disk, responds “too fast” to the Set Drive Parameters command.

P.S. There seems to be hints people managed to hack/patch the bug out. There is no documentation about that, and the process should be specific to the hacked versions.

1

I'm a bit late to this but I have successfully virtualised SCO 5.0.6 using libvirt and it runs in production for a small business client (20 telnet users).

IDE disk, pcnet NIC, 1 x kvm64 CPU, 256 MB RAM

I did type up a p2v document if you're still interested.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.