0

EDIT: I should mention that my mouse and keyboard are wireless devices. I assume that doesn't matter since a Live version of Windows 7 had no problems with it, and the most basic part of my system (BIOS?) allows me to use my peripherals no problem.

EDIT2: It turns out all of my devices work from my USB 3.0 ports, in case this helps anyone. I'll post as I find more.

My very, very novice understanding of Linux is that I need to create a bootable .iso with some software that allows me to boot into a no-changes-saved, low memory version of the desired OS that loads and operates purely off RAM, known as a "Live version." Only from there can I do a full install, maybe b/c Windows can't format storage partitions to the whimsical, wonderful, phantasmagorical "Ext 4" filesystem? Welp, I can't do ANYTHING b/c once I manage to boot my Live OS from either my flash drive or external HDD, my keyboard and mouse no longer respond. I have to cut the power to turn off the computer (which I'm sure is not great).

I've never used a Linux OS, but I've been trying to for the last week. No matter what bootable USB software I use to set up my device (Rufus, unetbootin, YUMI), I always run into the same problems, starting with a black screen. Monitors turned off automatically, receiving no signal once I got past the boot screen. Eventually I awkwardly found my way past the black screen problem via the "Grub" commands with Google results and found to either select "nomodeset" or edit whatever line of text ends with "splash --", inserting nomodeset in before the double-hash. My computer has an NVIDIA graphics card; I'm assuming that was the problem?

Either way, now I just cannot interact with these OS's without a keyboard or mouse, even though I can see their swell-looking desktops. I really thought these community-based OS's caught up to the big-company ones. Am I doing shit wrong? :(

enter image description hereenter image description hereThis is basically what I see for a few seconds before the every OS loads its desktop.

  • You don't need to boot a live distribution, there are also installation CD images etc. that will do the install directly. The NVidia card may need the proprietary driver, this is normally not included in live distros. Keyboard not working is a problem, however. What keyboard do you have exactly? A bluetooth one with a dongle? – dirkt May 18 '17 at 6:26
  • I have no idea what a dongle is lol. This is my keyboard: amazon.com/gp/product/B007PJ4PN2 – Spiffyriffic May 18 '17 at 8:35
0

Your keyboard uses a Logitech Unifying Receiver dongle. A dongle is a small device that goes into the USB ports and transmits and receives the wireless signals.

For support for this dongle under Linux see e.g. here. It specifically says that there are problems during boot, because the dongle uses a proprietary HID module. So you either need the hid-logitech-hidpp module, or you need to enable the logitech-djreceiver driver in the kernel, neither of which may not be available in Live Distributions.

The error messages seem to indicate general trouble reading from USB ports, so maybe there's also a problem with the USB host adapter drivers.

I'm not sure what to recommend, because to fix the first issue you either need to make your own bootable iso image (which isn't easy for a novice), or to find some iso image which will include this drivers (which will need a lot of trial and error).

Maybe the easiest solution is to borrow a USB keyboard somewhere, install Linux properly, make sure this module is installed, make sure it boots correctly without the USB keyboard, and then return the USB keyboard.

Another thing you can try is to remove all other USB devices, and maybe try the dongle in different ports - if it's a problem with USB host adapters, you may be lucky and hid a good configuration.

  • Tried a wired keyboard with the same result. Trying to edit the initramfs.conf file to include the logitech module thingy from the website you linked me to. I appreciate the very helpful info; still running in circles with this. Every idea for a solution just introduces a new problem... – Spiffyriffic May 20 '17 at 6:24
  • Was that a wired USB keyboard? That would point to "USB host adapters not working". It would be interesting to see the part of the boot process where it initializes the USB host adapters, but without a keyboard it's probably difficult. Other ideas, none if them easy: (1) Try to find a PS/2 keyboard (2) use the serial port as console (3) use netconsole to get at the full boot log. This is getting pretty advanced now. – dirkt May 20 '17 at 17:22
  • I just noticed that all of my USB 3.0 ports are working for both wired and wireless devices. I didn't notice before because I was using them for my 3.0 storage devices (the ones I'm booting from) and my extra 3.0 ports are harder to access. Not sure why this is or how to fix my 2.0 ports for all these Linux Live OS's, but if I find anything out I'll post it here. – Spiffyriffic May 21 '17 at 22:14
  • If you can boot with a keyboard connected to an USB 3.0 port, please open a terminal window directly after boot, type dmesg and put the output in a pastebin etc (you can use dmesg > file_name to put the output in a file). Do the same for lspci -nn (cut and paste should be sufficient). Edit your question with a link to the pastebin, ping me in a comment, and I'll have a look. – dirkt May 22 '17 at 6:41
0

I encountered an issue like this in Linux Redhat (I do not recall the version). During the boot up, I kept seeing messages where the OS was attempting to detect a USB device. It was clearly failing and making multiple attempts. I was able to bypass this issue by unplugging the optical mouse during the boot process. Once Linux finished booting up, I was able to reconnect the mouse and use it properly. I'm not saying this will work for you, but it is worth trying.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.