4

I'm trying to compile ffmpeg with hwaccel support, but no matter the options I pass to the configure script, the enable hwaccels list always comes empty.

Running ./configure --help says that, to enable a hwaccel, I should pass --enable-hwaccel=NAME, where NAME comes from the list of hwaccels supported.

I tried doing all of these (appending the option at the end of my ./configure command):

--enable-hwaccel=mpeg1_vdpau
--enable-hwaccel mpeg1_vdpau
--enable-hwaccel=mpeg1
--enable-hwaccel=mpeg1*

But none of these helped. Can someone give me a light?

Edit: I added --enable-vdpau before --enable-hwaccel, and now it gives me this error: ERROR: vdpau requested, but not all dependencies are satisfied: vdpau_vdpau_h vdpau_vdpau_x11_h

I installed libvdpau-dev, but the error persists.

Edit2: I am cross-compiling ffmpeg for an ARM target (an AM3352, which as a SGX530 graphics accelerator) , does this have any influence on the hwaccel options?

  • (guessing ffmpeg works like a normal configure) Check your config.out or config.log to see where it is running the tests for those. Probably you're missing a some headers (e.g., from a -dev/-devel package) – derobert May 16 '17 at 16:30
  • Could it have anything to do with the fact that I am cross-compiling? There is no indication of any error, but from the config.log file it seems that the option is not being selected, regardless of what I pass to the script. – Guilherme Costa May 16 '17 at 17:16
  • Yeah... you'll need to make sure those headers are available for your cross-compiler, not your host system's compiler (and similarly, that the libs to link against for your cross-linker, not the host system's). – derobert May 16 '17 at 17:45
  • Also: you should consider if this would better fit on Stack Overflow than here. If you want it moved, flag your question, select "in need of moderator intervention", and ask for it to be moved to Stack Overflow. – derobert May 16 '17 at 17:48
  • I wouldn't really consider building someone else's app to be a programming question – Michael Mrozek May 16 '17 at 18:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.