3

I have a VM for FreeBSD 11-STABLE and whenever I run pkg upgrade -y on it, the thing tries to install three packages, the most notable of which is vim, then reboots without installing the packages correctly. I know they are not installed correctly as after the reboot I run pkg upgrade -y again and the system tries to install those packages again and fails and then reboots. Now, obviously something is broken. So I rebooted it with a live ISO inserted for the latest FreeBSD 11-STABLE snapshot and in the live session I mounted my FreeBSD root partition (although it did need me to run fsck on this partition before I could mount it) and chrooted into the damaged system. In there I am running pkg upgrade -y in the hope that installing those three packages in an environment wherein I doubt a reboot will be triggered would be the answer. I know that when a VM of mine for Linux gets broken if I chroot into the system and perform a system update usually the update fixes things.

The problem I am having is that running pkg upgrade -y in this chroot is trying to download data (and I have no internet in this live session, tried following https://www.freebsd.org/doc/handbook/config-network-setup.html but it doesn't seem to be working), to see if the meta.txz and other repo data files are up-to-date. Is there a way to tell it just to use the existing repo data and the already fetched 3 packages (the ones that trigger the reboot), thereby eliminating the need to download any data? Running pkg help upgrade didn't reveal anything to me that looked helpful. I searched it for download and no matches were found.

Problem with using ports as an alternative though is that the build is failing for me. Building Vim is the biggest issue, as at the stage of building the gmake package (obviously somewhere in its dependency tree) I get an error and it says setting MAKE_JOBS_UNSAFE=yes will silence it. I do that and I then get an error. I would give you's a log but my usual method of getting a log that I can pastebin, is to run:

COMMAND > error.log 2>&1

and then pastebining the error.log file. But in csh this fails with the error:

Ambiguous output redirect.

EDIT: Nvm I found what to do with csh to get the log (using COMMAND >& error.log per this SO answer). Pastebinit is failing on me (error: Failed to connect to server: [Errno socket error] [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:661)) when I try to pastebin it. The build of wgetpaste also failed.

  • Are you perchance using bridged networking with Virtualbox? – schaiba May 16 '17 at 14:46
  • Nope NAT. Network works fine in the FreeBSD 11-STABLE installation (not the live session, the actual damaged installation). – BH2017 May 16 '17 at 14:47
  • I know FreeBSD pkg has some issues downloading packages, but I only have those issues in Bridged mode, NAT works. You can try to use ports instead to see if that works. – schaiba May 16 '17 at 14:50
  • Hrm, just a few weeks ago I decided ot checkout FBSD and used VirtualBox on a bridged connection, no issues. – ivanivan May 16 '17 at 15:07
  • @schaiba Added mention of the problem with the Ports method to question. – BH2017 May 16 '17 at 15:09
0

Have you tried pkg upgrade -U -y?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.