1

I have Debian GNU/Linux 9.0 installed on my PC and it is login without password (normal and root users), I tried to changed password using passwd command but it is not possible I received only the following message:

Running like normal user
$ passwd 
passwd: password updated successfully

Running as root user
# passwd myuser
passwd: password updated successfully

# passwd
passwd: password updated successfully

Also in the login window user can login without password.

Anyone has an idea how can I solve this issue?

Update 1

grep myuser  /etc/passwd 
myuser:x:1000:1000:myuser,,,:/home/myuser:/bin/bash

# grep myuser  /etc/shadow
myuser:admin1234:17302:0:99999:7:::

# grep root  /etc/passwd 
root:x:0:0:root:/root:/bin/bash
nm-openvpn:x:136:146:NetworkManager OpenVPN,,,:/var/lib/openvpn/chroot:/bin/false

# grep root  /etc/shadow
root:admin1234:17302:0:99999:7:::

Update 2

There is not file /etc/pam.d/password


# cat /etc/pam.d/common-password 
#
# /etc/pam.d/common-password - password-related modules common to all services
#
# This file is included from other service-specific PAM config files,
# and should contain a list of modules that define the services to be
# used to change user passwords.  The default is pam_unix.

# Explanation of pam_unix options:
#
# The "sha512" option enables salted SHA512 passwords.  Without this option,
# the default is Unix crypt.  Prior releases used the option "md5".
#
# The "obscure" option replaces the old `OBSCURE_CHECKS_ENAB' option in
# login.defs.
#
# See the pam_unix manpage for other options.

# As of pam 1.0.1-6, this file is managed by pam-auth-update by default.
# To take advantage of this, it is recommended that you configure any
# local modules either before or after the default block, and use
# pam-auth-update to manage selection of other modules.  See
# pam-auth-update(8) for details.

# here are the per-package modules (the "Primary" block)
password        [default=1]                     pam_permit.so
# here's the fallback if no module succeeds
password        requisite                       pam_deny.so
# prime the stack with a positive return value if there isn't one already;
# this avoids us returning an error just because nothing sets a success code
# since the modules above will each just jump around
password        required                        pam_permit.so
# and here are more per-package modules (the "Additional" block)
# end of pam-auth-update config
  • Should have worked. What do you see on the lines for these users in /etc/passwd and /etc/shadow? Does anything different happen if you try and use <i>usermod</i>? – Nadreck May 16 '17 at 3:23
  • I appended the result for root and myuser of these files. – omixam May 16 '17 at 4:52
  • 2
    The prime suspect is pam. – Satō Katsura May 16 '17 at 6:07
  • Please show us the contents of /etc/pam.d/password and /etc/pam.d/common-password. – Ferenc Wágner May 16 '17 at 10:35
  • I added the file content of /etc/pam.d/common-password, but there is not file called /etc/pam.d/password. – omixam May 17 '17 at 0:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.