1

I was trying to dist-upgrade my Debian based system. I have a lot of dependencies problem. I tried apt-get install <package-name>. But I get the same dependency problem reverted, like if it was in a loop. Tried apt-get install -f. Same dependency error. dpkg --configure -a. Same thing. apt-get update apt-get dist-upgrade apt-get dist -upgrade -f. Same error thing.

The only thing I think about is to reinstall the system. Is there another way to fix that problem?

The output error message is French. But the accent characters doesn't show well because I copy the output and send it to my phone....

    root@###:~# apt-get dist-upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 cpp-6 : Dépend: gcc-6-base (= 6.3.0-16) mais il n'est pas installé
 dmsetup : Dépend: libdevmapper1.02.1 (>= 2:1.02.131) mais 2:1.02.74-7 est installé
 dpkg-dev : Dépend: libdpkg-perl (= 1.16.10) mais 1.18.23kali1 est installé
 krb5-multidev : Dépend: libgssrpc4 (= 1.15-1) mais 1.10.1+dfsg-5+deb7u1 est installé
                 Dépend: libkadm5srv-mit11 (= 1.15-1) mais il n'est pas installé
                 Dépend: libkadm5clnt-mit11 (= 1.15-1) mais il n'est pas installé
 libalgorithm-diff-xs-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
 libc6-i686 : Pré-Dépend: libc6 (= 2.13-38) mais 2.24-10 est installé
 libcairo-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
 libclass-c3-xs-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
 libclass-load-xs-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
 libcrypt-ssleay-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
 libdbd-mysql-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
 libdbd-sqlite3-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
 libdbi-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
 libdigest-crc-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
 libdigest-md4-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
 libfile-fcntllock-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
 libfilter-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
 libfontconfig1 : Dépend: fontconfig-config (= 2.9.0-7.1) mais 2.11.0-6.7 est installé
 libglib-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
 libgtk2-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
 libhtml-parser-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
 libkpathsea6 : Casse: texlive-base (< 2014) mais 2012.20120611-5 est installé
 liblist-moreutils-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
 liblocale-gettext-perl : Pré-Dépend: perlapi-5.14.2 mais il n'est pas installable
 liblvm2app2.2 : Dépend: libdevmapper1.02.1 (>= 2:1.02.135) mais 2:1.02.74-7 est installé
 liblzma-dev : Dépend: liblzma5 (= 5.1.1alpha+20120614-2) mais 5.2.2-1.2+b1 est installé
 libmoose-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
 libnet-dbus-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
 libnet-dns-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
 libnet-pcap-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
 libnet-rawip-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
 libnet-ssh2-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
 libnet-ssleay-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
 libnss3-1d : Dépend: libnss3 (= 2:3.14.3-1) mais 2:3.26.2-1 est installé
 libpackage-stash-xs-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
 libpango-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
 libparams-classify-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
 libparams-util-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
 libpcsc-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
 libperl5.14 : Dépend: perl-base (= 5.14.2-21) mais 5.24.1-2 est installé
 libptexenc1 : Casse: texlive-base (< 2014) mais 2012.20120611-5 est installé
 libpurple0 : Dépend: perlapi-5.14.2 mais il n'est pas installable
 libsnmp-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
 libsocket6-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
 libsub-identify-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
 libsub-name-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
 libterm-readline-gnu-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
 libtext-charwidth-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
 libtext-iconv-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
 libtinfo-dev : Dépend: ncurses-bin (>= 6.0+20151017) mais 5.9-10 est installé
 libuuid-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
 libvariable-magic-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
 libxml-libxml-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
 libxml-parser-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
 libyaml-syck-perl : Dépend: perlapi-5.14.2 mais il n'est pas installable
 locales : Dépend: libc-bin (> 2.24) mais 2.13-38 est installé
           Dépend: libc-l10n (> 2.24) mais il n'est pas installé
 locales-all : Dépend: libc-l10n (> 2.24) mais il n'est pas installé
 lsof : Dépend: libperl4-corelibs-perl ou
                 perl (< 5.12.3-7) mais 5.24.1-2 est installé
 nfs-common : Dépend: libdevmapper1.02.1 (>= 2:1.02.97) mais 2:1.02.74-7 est installé
              Dépend: keyutils mais il n'est pas installé
 perl-tk : Dépend: perlapi-5.14.2 mais il n'est pas installable
 python : Dépend: python-minimal (= 2.7.3-4) mais 2.7.13-2 est installé
 python-dev : Dépend: python (= 2.7.13-2) mais 2.7.3-4 est installé
              Dépend: libpython-dev (= 2.7.13-2) mais il n'est pas installé
 tex-common : Casse: texlive-base (< 2015) mais 2012.20120611-5 est installé
 texlive-base : Dépend: texlive-common (>= 2012.20120516) mais il n'est pas installable
                Dépend: luatex (>= 0.70.1)
 texlive-binaries : Dépend: libfontconfig1 (>= 2.11) mais 2.9.0-7.1 est installé
                    Dépend: libgraphite2-3 (>= 1.2.2) mais il n'est pas installé
                    Dépend: libharfbuzz-icu0 (>= 0.9.18-3) mais il n'est pas installé
                    Dépend: libharfbuzz0b (>= 0.9.18-3) mais il n'est pas installé
                    Dépend: libicu57 (>= 57.1-1~) mais il n'est pas installé
                    Dépend: libpoppler64 (>= 0.48.0) mais il n'est pas installé
                    Dépend: libpotrace0 mais il n'est pas installé
                    Dépend: libstdc++6 (>= 5.2) mais 4.7.2-5 est installé
                    Dépend: libzzip-0-13 (>= 0.13.56) mais il n'est pas installé
                    Casse: texlive-base (< 2016) mais 2012.20120611-5 est installé
 texlive-doc-base : Dépend: texlive-common (>= 2012.20120516) mais il n'est pas installable
 texlive-latex-base : Dépend: fonts-lmodern mais il n'est pas installé
                      Dépend: texlive-base (>= 2016.20170123-2) mais 2012.20120611-5 est installé
                      Casse: texlive-base (< 2016.20170123-2) mais 2012.20120611-5 est installé
 texlive-latex-base-doc : Dépend: texlive-base (>= 2016.20170123-2) mais 2012.20120611-5 est installé
 texlive-luatex : Dépend: texlive-base (>= 2016.20170123-2) mais 2012.20120611-5 est installé
                  Casse: texlive-base (< 2016.20170123-2) mais 2012.20120611-5 est installé
E: Dépendances manquantes. Essayez d'utiliser l'option -f.

dpkg --configure -a

Output package errors:

python-dev nfs-common libtinfo-dev:i386 texlive-binaries texlive-luatex krb5-multidev locales-all texlive-base dmsetup liblvm2app2.2:i386 cpp-6 texlive-latex-base locales texlive-latex-base-doc cpp libkrb5-dev

apt-cache policy output:

root@xxxx:~# apt-cache policy 

Fichiers du paquet : 100 /var/lib/dpkg/status release a=now 
500 http://http.kali.org/kali/ kali-rolling/non-free i386 Packages release o=Kali,a=kali-rolling,n=kali-rolling,c=non-free origin http.kali.org



500 http://http.kali.org/kali/ kali-rolling/contrib i386 Packages release o=Kali,a=kali-rolling,n=kali-rolling,c=contrib origin http.kali.org 
500 http://http.kali.org/kali/ kali-rolling/main i386 Packages release o=Kali,a=kali-rolling,n=kali-rolling,c=main origin http.kali.org Paquets épinglés :
  • 1
    Ok. I edited the question – user3502626 May 16 '17 at 3:23
  • Please show us the output of apt-cache policy. – Ferenc Wágner May 16 '17 at 10:37
  • Edited for apt-cache policy – user3502626 May 16 '17 at 13:51
  • Is apt upgrade working as expected? – schaiba May 16 '17 at 13:54
  • No. It shows the dependency error. Only apt update works – user3502626 May 16 '17 at 14:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.