0

With the command

sudo apt-get install gnome-core -f

I got

The following packages have unmet dependencies:
          gnome-core : Depends: nautilus (>= 3.22) but it is not going to be installed
                       Depends: gnome-sushi (>= 3.20) but it is not going to be installed
          E: Unable to correct problems, you have held broken packages.

So i tried:

sudo apt-get install nautilus -f

I got:

The following packages have unmet dependencies:
        nautilus : Depends: libnautilus-extension1a (= 3.22.3-1) but it is not going to be installed
                   Recommends: gnome-sushi but it is not going to be installed
        E: Unable to correct problems, you have held broken packages.

After I tried:

sudo apt-get install gnome-sush -f

I got:

The following packages have unmet dependencies:
        gnome-sushi : Depends: nautilus (>= 3.2) but it is not going to be installed
        E: Unable to correct problems, you have held broken packages.

Finally I tried:

sudo apt-get install libnautilus-extension1a -f

And I obtained:

libnautilus-extension1a is already the newest version (1:3.14.2-0ubuntu9).

I tried also to clean using (sudo is missing because i was root):

apt-get clean && apt-get update && apt-get upgrade -y && apt-get dist-upgrade -y

source.list

deb http://http.kali.org/kali kali-rolling main contrib non-free

deb http://security.debian.org/debian-security wheezy/updates main

deb http://ppa.launchpad.net/webupd8team/java/ubuntu trusty main

deb-src http://ppa.launchpad.net/webupd8team/java/ubuntu precise main

OS

4.9.0-kali4-amd64 #1 SMP Debian 4.9.25-1kali1 (2017-05-04) x86_64 GNU/Linux

2
  • 2
    Could you add your /etc/apt/sources.list? May 15, 2017 at 13:54
  • @EsaJokinen sorry, I just added it.
    – Hoper
    May 15, 2017 at 13:59

2 Answers 2

3

You have held broken packages because you have a mixed sources.list : debian wheezy , ubuntu trusty , precise and kali rolling

Edit your sources.list , only keep the following line:

deb http://http.kali.org/kali kali-rolling main contrib non-free

Update your package

apt-get update
apt-get upgrade
apt-get dist-upgrade
apt-get -f install

Then install gnome desktop:

apt-get install gnome-core kali-defaults kali-root-login desktop-base
2
  • 1
    The package libnautilus-extension1a wasn't from any of the sources. The launcpad.net trusty/precise only contained Java for Ubuntu, and 3.12.2-0ubuntu9.1 is from Vivid. I suppose it's manually installed from a .deb package. Kali is based on Debian testing: I think it could actually get security updates from debian-security stretch/updates, but not from the wheezy/updates in current setting. May 15, 2017 at 19:50
  • Kali sources.list Repositories documentation is in line with this answer: "The single most common causes of a broken Kali Linux installation are following unofficial advice, and particularly arbitrarily populating the system’s sources.list file with unofficial repositories. - - Any additional repositories added to the Kali sources.list file will most likely BREAK YOUR KALI LINUX INSTALL." May 16, 2017 at 9:22
2

You are not using Debian, but Kali. Then, for some reason, you are having this package libnautilus-extension1a 1:3.14.2-0ubuntu9.1 from Ubuntu Vivid, while Kali-rolling (& Stretch) has 3.22.3-1.

You could use

sudo dpkg --remove --force-remove-reinstreq --force-hold libnautilus-extension1a

to remove it. From man dpkg:

hold A package marked to be on hold is not handled by dpkg, unless forced to do that with option --force-hold.

reinst-required A package marked reinst-required is broken and requires reinstallation. These packages cannot be removed, unless forced with option --force-remove-reinstreq.

Then you can sudo apt-get update and try to reinstall from your normal apt sources.

1
  • You are right i had to remote it manually first, and after update and upgrade.
    – Hoper
    May 16, 2017 at 9:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .