0

I am using rysnc via Cygwin on Windows 7 Professional.

$ rsync -version
rsync  version 3.1.2  protocol version 31

I am trying to set up a backup using rsync to a USB drive.

I ran the following command:

rsync -v -rplt "/cygdrive/k/Email/" "/cygdrive/d/Backup Files/k/"

[ I got the same result with "-rlt" flags, I added the "p" flag to instruct rsync to copy the persmissions"].

This seems to work fine, however when I try to look at the results I get permission denied messages:

$ ls /cygdrive/d/Backup\ Files/k
ls: cannot open directory '/cygdrive/d/Backup Files/k': Permission denied

I cannot access via Windows Explorer either.

If I unplug the USB drive and connect to another PC I can see the files.

  • Hello TenG. What filesystem is being used on the K: drive? What filesystem is being used on the USB D: drive? (FAT32? NTFS? REFS? Something else?) Is the K: drive local or remote? Please edit your question to provide this information. – roaima May 14 '17 at 21:01
0

Make sure you don't have "chattr" enabled for the folder/file/contents of the USB storage

Try to first execute this :

chattr -R -ai <folder>

or

 chattr -R -ai <files>

and then do rsync and ls command to check if it gives a permission denied message.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.