0

I'm facing a strange issue, which was revealed to me only because I bought a dual-band wireless router, namely a TP-Link Archer C2 AC750 (sic) with 2.4Ghz and 5GHz wireless access point. Before that I had an old Linksys WRT54G that I had flashed with DD-WRT.

A while ago my router started to act weirdly and I assumed the Flash memory wore out — I had used for years the NVRAM to hold the system log and DHCP leases. In parallel I also noticed Network Manager on my Manjaro laptop would no longer list my Linksys access point.

EDIT: Following this I could also confirm iwlist scan wouldn't list my ESSID either.

  • Since I bought the new one I noticed my laptop would connect to my access point using the 5GHz band only.
  • My Android phone (anyone else's as well) can connect to my AP's 2.4GHz band.
  • Also my laptop can connect to any other 2.4 GHz band so far, especially at work.
  • I tried booting with (a not-so-recent) Linux BBQ distribution, same symptoms: only my 5G network is visible (from iwlist scan).

It's just at home, with my own router that my laptop seemingly refuses to use the 2.4GHz band. And I have no idea why.

For the record, my laptop is a Dell Latitude E6530. It has a Broadcom wireless chipset: BCM43228 802.11a/b/g/n. It runs Manjaro and IIRC I have kept the default network configuration from the installation on in 2015. None of the kernel series I tried did anything new.

Does anyone have a hint?

| improve this question | | | | |
  • Have you tried changing the channel? Maybe the AP is configured to use a channel which is not supported by your laptop potentially due to regional issues. – sammko May 14 '17 at 18:47
  • @sammko yup, I did. I tried channels 6 & 11, no effect whatsoever. Note that I'm "surrounded" with a few wireless networks, all on channel 1. – user86969 May 14 '17 at 18:56
  • Try running iwlist scan from the wireless_tools package and see whether the AP is listed in the output. Maybe only Network Manager is not listing it for whatever reason. – sammko May 14 '17 at 21:56
  • No, it' not listed by iwlist scan, which is what I wanted to indicate with «ignores bla [...]» – user86969 May 15 '17 at 7:59
1

After ordering a new wireless adapter from Dell and replacing the old one I noticed the old card... had nothing wrong! I strongly suspect the connector, which is similar to an M.2 socket, is flawed by design and oxidation settles with time, making contacts less efficient.

As a proof I used my old wireless adapter in another computer, which had almost exactly the same symptoms and it worked like a charm! Simply removing the adapter and softly sanding the contacts with a highly fine grained sand paper is enough to make the contacts work again. Just for kicks, I placed my old wireless adapter back into my laptop and it worked a treat!

If it happens to you — your wireless card starts to behave strangely, connects then disconnects, doesn't seem to do anything logical — and you don't want to use sand paper, just remove the adapter from its socket, gently move it within its socket and place it back. The socket contacts will be rubbed against the pads of the PCB, which should be enough to make the wireless adapter work again.

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy