On my Arch Linux system, I installed Windows 10 afterwards. Therefore, Windows overwrote the EFI partition and I had to set it up again (because my Arch Linux uses EXT4, so Windows Boot Manager won't work). I managed to install GRUB but for some reason, the Arch installation is not detected; from GRUB, I can only boot into Windows 10.

I tried both efibootmgr and grub-install (followed by grub-mkconfig) and neither of them show results. In my boot startup, both show up as possible selections. The former brings me to GRUB, where I can select to boot Windows; and the latter seems to do nothing at all when I select it.

This is my first time using Arch Linux and my first time using UEFI, so I am at a loss here.

  • grup-update in my case i lost windows, i had only linux, and this worked for me ! – BOUKANDOURA Mhamed May 15 '17 at 8:59
  • 1
    The case you are describing occurs frequently and seems to be very different from mine. grub-update e.g. didn't do anything for me. I solved it with systemmd now. however. – Andreas T May 17 '17 at 10:51

Since nobody has yet been able to provide an answer, may I suggest another solution: dump GRUB and use systemd-boot instead. See the Arch Wiki systemd-boot page. GRUB is not really needed on UEFI systems, and systemd-boot is much simpler to configure than GRUB.

  • Will that work with the dual boot though? According to this, GRUB and Syslinux are my only options. – Andreas T May 15 '17 at 7:57
  • Yes, it will work. The link you provided has the caption "BIOS systems", in the document "BIOS" is the opposite of "UEFI". – Johan Myréen May 15 '17 at 8:05
  • While not exactly answering my question, this solved my problem nice and easy, so I'll mark it as accepted. Thanks. – Andreas T May 17 '17 at 10:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.