2

I have a chromebook. Linux is on it but I wanted a copy to boot from USB. Legacy boot is enabled and I was able to boot the install/live cd via USB. I installed to sdb and installed grub there too. To boot to chrome I press ctrl+d. To boot into linux or the USB I press ctrl+d. When I try booting to the USB it skips it like it doesn't exist and goes to linux.

I used fdisk and set the bootable flag but it didn't seem to solve it. Grub shows set root='hd1,msdos1 which I believe is correct? The USB should always be loaded at /dev/sdb. I have no idea what to do/change besides making sure grub exist on the first partition and making sure it's marked as bootable. I'm not sure how much this affects things but it's an encrypted LVM partition. When running Linux via chromebook I get a prompt to unlock the partition but I only want to boot from this

  • Are you trying to make a bootable USB with persistance ? – GAD3R May 13 '17 at 9:12
  • @GAD3R: I believe so. It should be like a normal installation the only difference is instead of using an internal HD it's a USB (my main system has the second internal drive as the windows system with the other two data) – user4069 May 13 '17 at 16:58
  • @acidzombie24 No there is actually a difference: there is the possibility to use live media with an overlay filesystem to store modified data and on the other there is just installing to USB – LiveWireBT May 13 '17 at 18:08
0

To boot to chrome I press ctrl+d. To boot into linux or the USB I press ctrl+d.

You either mean ctrl+u to boot directly from USB or ctrl+l to boot legacy and choose to boot the USB from SeaBIOS, which is what MrChromebox firmware is capable of and which you usually use to install another operating system on Chromebooks. Have you tried that? It looks like crossystem dev_boot_usb=1 dev_boot_legacy=1 doesn't work on every device, I just tried it on my N22 and only got two loud beeps via ctrl+u, but SeaBIOS works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy