3

Working on Linux Mint 18.1, VirtualBox 5.0.40_Ubuntu.

I have a VDI file from a VirtualBox VM:

~/VirtualBox\ VMs/Win10x64/Win10x64.vdi

I've taken a Snapshot:

~/VirtualBox\ VMs/Win10x64/Snapshots/{GUID}.vdi

I want to mount the guest's HDD from the snapshot.

I can successfully mount the base VDI using qemu-nbd:

qemu-nbd -c /dev/nbd0 ~/VirtualBox\ VMs/Win10x64/Win10x64.vdi

But if I try with the Snapshot file:

qemu-nbd -c /dev/nbd0 ~/VirtualBox\ VMs/Win10x64/Snapshots/{GUID}.vdi

it fails with:

unsupported VDI image (non-NULL link UUID)

I did notice the --snapshot parameter for qemu-nbd but this doesn't seem to be the right thing.

How can I mount the HDD as it is in the snapshot?

Edit #1 I've also tried vdfuse, but again, doesn't seem to be any way of "applying" the differencing disk.

  • @s_buttgereit As of today, August 2018, still no answer :( – Bridgey Aug 22 '18 at 14:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.