0

I had searched by google about the question I am going to address, but still don't understand what's the solution of my case. Based on my poor language communication skill, I am showing step-by-step about my question.

  1. I have connected to a linux server, like TACC-lonestar or other RedHat/Ubuntu server.
  2. I typed "gnome-terminal" to generate a new terminal to use.
  3. on the nav-menu, I clicked the "keyboard Shortcuts" to assign a new shortcuts for copy&paste.
  4. I doubled clicked the shortcut key for copy, trying to input "Meta+C" (command+c on mac), but this input is invalid. That is, keeping showing "New accelerator..." to me. That is, "Meta+C" is not functional.

My question is I can have shortcut key for "meta+X", "meta+v", "meta+a", "meta+b" and so on. I can have shortcut keys input like "shift+meta+c." But why I am not be able to input "meta+c". In fact, before I changed the copy shortcut key, the shortcut is "meta+c". But I don't know why I am not able to do it now.

Could someone help me to solve this issue?

Thank You

enter image description here

  • 1
    I thought that Meta mapped to the Option key, not the Command key? – DopeGhoti May 11 '17 at 17:17
  • no, it actually is command key. – Franke May 11 '17 at 18:41
  • 2
    I found a solution to solve it after coupled hours test. In the preferences of XQuartz, only need to select the "Follow system keyboard layout" on the input tab. Then I can change the shortcut key by "meta+c." Hoping this is useful. – Franke May 11 '17 at 18:41
  • @Franke you can and should post that as an answer, even though you wrote the question. – Wildcard May 12 '17 at 7:29
  • I see. I shouldn't write my answer on comment. Thanks – Franke May 31 '17 at 22:21
1

I found a solution by myself. Here is the answer.

To solve this situation, you need to go to the preferences of XQuartz. After you turn on the preferences and click the "Follow system keyboard layout" on the input tab only. Once it is done, you can change the shortcut key by "meta+c."

Hoping this is useful.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.