1

For over a year, I've been able to backup numerous Windows servers using Ubuntu Server 16.04, but this all stopped working on Tuesday May 9th 2017.

Here's how I'm mounting these windows file systems using fstab:

sudo nano /etc/fstab 

\\192.168.1.1\c$ /mnt/win2012r2 cifs credentials=/home/user/.smb,iocharset=utf8,sec=ntlm 0 0
\\192.168.1.2\d$ /mnt/win2008r2 cifs credentials=/home/user/.smb,iocharset=utf8,sec=ntlm 0 0
\\192.168.1.3\c$ /mnt/win2012 cifs credentials=/home/user/.smb,iocharset=utf8,sec=ntlm 0 0
\\192.168.1.4\d$ /mnt/win2008 cifs credentials=/home/user/.smb,iocharset=utf8,sec=ntlm 0 0

The /home/user/.smb file contains only this:

username=administrator2
password=s3cr3tPW
domain=company1

After a reboot, if I attempt to do a mount command, it shows that all of theses server's drives are already mounted to the linux file system:

sudo mount -a --verbose -vvv

/mnt/win2012r2           : already mounted
/mnt/win2008r2           : already mounted
/mnt/win2012             : already mounted
/mnt/win2008             : already mounted

However, if I try to list the directory where these mount-points are, it takes forever and eventually says these hosts are down:

ls /mnt

ls: cannot access 'win2012r2': Host is down
ls: cannot access 'win2008r2': Host is down
ls: cannot access 'win2012': Host is down
ls: cannot access 'win2008': Host is down

Above, is essentially the same error that I also see in my cron rsync logs:

failed: Host is down (112)

Again, this all started on Tuesday May 9th 2017. And, it is not just happening on this one network; its the same story at a completely different company where I'm using the same method for backup.

Lastly, no settings have been changed recently on these backup servers. I don't even recall explicitly doing any updates between May 8th and 9th.

2
  • 2
    On Monday night Microsoft issued an emergency update because of a vulnerability in its own anti-virus engine. If this was installed (maybe automatically) there may be a link. Commented May 11, 2017 at 10:03
  • Are you able to unmout the share and remount it from the command line?
    – jc__
    Commented May 11, 2017 at 14:39

1 Answer 1

1

Temporary hack.

I have encountered the same error when mounting from the command line.

sudo mount -t cifs //ls2/jc /mnt/ls2 -o username=jc

I did not get an error, "Host is down", until I tried to access both the share directory /mnt/ls2 AND /mnt.

ls /mnt/ls2

ls /mnt

I then unmounted the share sudo umount /mnt/ls2 then remounted using the very same command as before sudo mount -t cifs //ls2/jc /mnt/ls2 -o username=jc.

Everything worked.

Important note:

The share at //ls2/jc is not on a Microsoft box, but on Ubuntu 14 server updated current running smbd Version 4.3.11-Ubuntu. and uname -a output:

Linux ls2 4.4.0-75-generic #96~14.04.1-Ubuntu SMP Thu Apr 20 11:06:56 UTC 2017 i686 i686 i686 GNU/Linux

Client where mount command executed uname -a output:

Linux tec3 4.4.0-75-generic #96~14.04.1-Ubuntu SMP Thu Apr 20 11:06:30 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

Client mount version:

mount from util-linux 2.20.1 (with libblkid and selinux support)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .