1

After copying the last version of Stretch distro on a 4GB USB drive with sudo dd bs=4M if=debian-testing-amd64-netinst.iso of=/dev/sdb1 && sync on a Lubuntu 16.04 system, the file system of sdb1 shows as 'unknown'. This is the case after creating a ms-dos or gpt partition table, a single partition, and formatting it with ext4 or FAT32 file system, which shows correctly after formatting, but goes to unknown after the dd command completes. Actually, the drive does not boot the computer, it simply gets stuck (although this might be caused by other reasons). I've also tried, with the same result, after executing isohybrid on the ISO file.

5

You need to overwrite the USB key including its partition table:

sudo dd bs=4M if=debian-testing-amd64-netinst.iso of=/dev/sdb

(sdb instead of sdb1). The download contains its own partition table.

See the official instructions, which suggest

sudo cp debian-testing-amd64-netinst.iso /dev/sdb
sync

instead.

As pointed out by Mioriin, you should verify the downloaded image before copying it to your key, to make sure it was downloaded correctly and more importantly that it hasn’t been tampered with.

| improve this answer | |
  • Then, in such a case, it's not neccesary to prepare the pen drive in any way, just plug it in and dd the ISO. – nightcod3r May 10 '17 at 15:37
  • @nightcod3r exactly. – Stephen Kitt May 10 '17 at 15:47
-2

This is likely a corrupted download. Get the checksum signatures from the download page you got the .iso from and validate your downloaded file. (it should have the instructions you need to perform the check)

If it fails the check, you need to download the image again and check that.

Repeat until the file passes the check. Then you have an image file that works.

| improve this answer | |
  • I missed the partition number in the question, but I'm leaving the answer up since it's a good idea to validate downloaded .iso images before using them. – Mio Rin May 10 '17 at 5:03
  • 1
    I agree it’s a good idea to verify downloads, but it needs to be done properly — using checksums obtained from the same place as the downloaded image isn’t sufficient. – Stephen Kitt May 10 '17 at 5:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.