2

I need to migrate from one Windows X-Server product (X2Go) to an other (MobaXterm). I have a Unix application that works nicely under the old X-Server, but complains about missing fonts on the new X-Server. I tried to manually copy my fonts from one X-Server to the other (copy files, then xset fp+ path then rehash etc. ...), some fonts were taken over (fewer missing fonts messages), but some are still missing. The missing fonts are given in XLFD format e.g.:

XLoadQueryFont for "-b&h-lucidatypewriter-medium-r-normal-sans-12-*-*-*-m-*-iso8859-1" failed.

I would like to find out which files contain the missing fonts, and how to migrate them to the new X-Server. I already grep-ped through my font files and fonts.dir file for the XLFD font names, but no luck.

  • Do these X servers use fontconfig? If they do, you probably want to look for fontconfig, err, config files. – Satō Katsura May 9 '17 at 9:52
  • I can issue the fc-list command in both cases, and the results are identical, no difference, but the application misses a couple of fonts in case of the MobaXterm X-Server, and runs without problems in case of X2Go. – swizzly May 9 '17 at 10:26
1

Grepping my /usr/share/fonts/X11/*/fonts.dir finds e.g.

lutRS12-ISO8859-1.pcf.gz -b&h-lucidatypewriter-medium-r-normal-sans-12-120-75-75-m-70-iso8859-1

and

$ dpkg -S lutRS12-ISO8859-1.pcf.gz
xfonts-75dpi: /usr/share/fonts/X11/75dpi/lutRS12-ISO8859-1.pcf.gz
xfonts-100dpi: /usr/share/fonts/X11/100dpi/lutRS12-ISO8859-1.pcf.gz

finds that these are in the xfonts packages on Debian (and probably on Debian derivatives as well).

I've no idea how to obtain them for MobaXterm, but I suppose you can extract them from the Debian packages, if you don't find them directly.

If there are not in some kind of package on your system, I suppose you'll have to update fonts.dir manually, restart everything etc.

  • Hi @dirkt, thanks, but the lucida... was just an example, I already installed it. I have other perhaps proprietary fonts, that are still missing e.g. "-linotype-helvetica-medium-r-normal--18----p--iso8859-1". I can't even find on the old X-Server from which file are they coming from. – swizzly May 10 '17 at 15:20
  • "Linotype" sounds very proprietary, and it's e.g. not on my system. If the fontnames are not configurable somewhere in your application (via X resources), I think you can use fonts.alias to substitute other Helvetica fonts etc., but I've never tried that myself. – dirkt May 10 '17 at 15:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.