1

I recently download the latest version of GIMP (2.9.4) from their website, and extracted it. I read the INSTALL file and ran the configure script. However, when I do, it fails:

GIMP configuration failed.
The following mandatory dependencies are missing:
  - babl >= 0.1.18
  - gegl-0.3 >= 0.3.8
  - atk >= 2.2.0
  - gtk+-2.0 >= 2.24.10
      *** Test for GTK+ failed.
  - gdk-pixbuf-2.0 >= 2.30.8
  - gdk-pixbuf-csource
      *** Could not find gdk-pixbuf-csource in your PATH.
  - gexiv2 >= 0.6.1
  - libtiff
      *** Checks for TIFF library failed
  - libjpeg
      *** JPEG library not found
  - libjpeg
      *** JPEG header file not found
  - libjpeg
      *** JPEG library is too old
  - liblzma >= 5.0.0
  - libmypaint >= 1.3.0
  - lcms2 >= 2.6
  - Python 2 headers
      *** Please install them, or skip building the python scripting extension by
      *** passing --disable-python to configure (but then you will not be able
      *** to use scripts for GIMP that are written in Python).
  - PyGTK 2.10.4 or newer
      *** Please install it, or skip building the python scripting extension by
      *** passing --disable-python to configure (but then you will not be able
      *** to use scripts for GIMP that are written in Python).
  - pygtk-codegen-2.0 script
      *** Please install it, or skip building the python scripting extension by
      *** passing --disable-python to configure (but then you will not be able
      *** to use scripts for GIMP that are written in Python).
  - PyCairo 1.0.2 or newer
      *** Please install it, or skip building the python scripting extension by
      *** passing --disable-python to configure (but then you will not be able
      *** to use scripts for GIMP that are written in Python).

I have installed all of these manually via dnf, but somehow it's still not recognising some of the simplest packages like libjpeg. Does anyone know why it might not be reading the latest installed packages? I'm on Fedora 25.

  • check the paths you have installed the libs in your system or pass these as arguments as an argument in the configure script, besides why dont you try to use yum, the package manager are precisely to resolve the dependencies. – riccs_0x May 8 '17 at 23:38
  • 2
    Did you install the -devel packages, or just the runtime packages? – steeldriver May 9 '17 at 0:25
  • Just the normal packages, and in response to @riccs_0x, yum does not have the latest 2.9 packages. – carefulnow1 May 9 '17 at 0:48
  • 1
    as mentioned by steeldriver try instaling the devel packages, or compile with the proper arguments; the package managers usually are a bit behind the latest versions but the tradeoffs are that you wont have to resolve the dependencies one by one (besides there is nothing wrong with that !), and you dont broke your system. Check if there is some notes for fedora in the INSTALL file. – riccs_0x May 9 '17 at 0:53
  • @OliverDixon did you solve this? If yes, how? – Michael Schumacher Oct 22 '17 at 16:34
1

As mentioned in the comment by @riccs_0x, you are missing several development packages.

Instead of finding and installing them from your package management one by one, you can tell your package managers to install all of the dependencies of your distro's GIMP package (currently, this would be 2.8.22). Except for anything that was not required in 2.8.x at all - and you already found libmypaint and recent enough babl and gegl - this will resolve most, if not all, of the issues you have encountered.

The GIMP 2.9.x version may require more recent dependency versions than 2.8.x, but as GIMP tends to be pretty conservative with raising those, you'll likely have those anyway.

For installing dependencies of source packages, both yum and dnf provide the a builddep command. I don't use Fedora myself and can't try it, but my first attempt would be:

dnf builddep gimp

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.