1

I use linux Mint 18 Sarah MATE 64-bits.

I'm struggling with screen resolution. I installed Mint on September and until today it recognized my screen resolution (1600x1200) perfectly, but this morning it did not recognized it and I am trying to solve it. Now, the maximum resolution I can set is 1024x768. I have a NVIDIA video card, so I tried to change the controller from xserver-xorg-video-nouveau (default) to nvidia-340, but didn't gain much resolution, not 1600x1200 as I need (and always had).

Looking at many forums, specially this: https://community.linuxmint.com/tutorial/view/877, I've done so far:

cvt 1600 1200
sudo xrandr --newmode "1600x1200_60.00"  161.00  1600 1712 1880 2160  1200 1203 1207 1245 -hsync +vsync
sudo xrandr --addmode DVI-I-1 1600x1200_60.00
sudo xrandr --output DVI-I-1 --mode 1600x1200_60.00

At this point, the resolution changed pretty well (it does not fit the screen, but I guess it has a solution). But, as this change is attached to the session, I need to keep it after a reboot, so, following the tutorial, I pressed Alt+Ctrl+F1 and in the terminal wrote

sudo service mdm stop

came to terminal with Alt-Ctrl-F1 again, and wrote

sudo X -configure

to generate the file xorg.conf.new, as the forum says, but, after restarting mdm service and log in, the file is not created. I still don't know how to copy the output and paste is here, but the last thing it says is No device to configure

2

I have intel 945 chipset and Linux Mint 18.3 Mate 64. In "screens" I have unknown VGA1 display and cannot set resolution higher than 1024x748.

In directory "/usr/share/X11/xorg.conf.d" I created file "40-monitor.conf"(if already have, you need just edit file):

 Section "Monitor"

    Identifier          "Monitor0"
    Modeline "1440x900_60.00"  106.50  1440 1528 1672 1904  900 903 909 934 -hsync +vsync
    VendorName   "Monitor Vendor"
    ModelName    "Monitor Model"
EndSection

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "AccelMethod"    "UXA"
EndSection


Section "Screen"
   Identifier "Screen0"
    Device     "Intel Graphics"
    Monitor    "Monitor0"
    SubSection "Display"
               Viewport   0 0
               Depth     1
               Modes   "1600x900"
    EndSubSection
    SubSection "Display"
                Viewport   0 0
                Depth     4
                Modes   "1600x900"
    EndSubSection
    SubSection "Display"
                 Viewport   0 0
                 Depth     8
                 Modes   "1600x900"
    EndSubSection
    SubSection "Display"
                 Viewport   0 0
                 Depth     16
                 Modes   "1600x900"
    EndSubSection
    SubSection "Display"
                 Viewport   0 0
                 Depth     24
                 Modes   "1600x900"
    EndSubSection

EndSection

In my case I used info in section "Device" from file "20-intel.conf". I think if you have Geforce there should be file something like "xx-nvidia.conf".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.