1

I had never installed Gentoo. gcc has troubles with linux-4.9.16-gentoo.

livecd / # genkerel all
...
Cannot use config_cc_stackprotector_regular: -fstack-protector not supported by compiler
make: *** [Makefile:1066: prepare-compiler-check] Error 1
Failed to compile "prepare" target...

livecd / # ls -l /usr/src/linux
... linux-4.9.16-gentoo
livecd / # gcc --version
gcc (Gentoo 5.4.0-r3 p1.3, pie-0.6.5) 5.4.0

livecd / # cat /etc/portages/make.conf
...
CFLAGS="-O2 -march=i686 -pipe"
CXXFLAGS="${CFLAGS}"
CHOST="i686-pc-linux-gnu"
USE="bindlist -gnome -kde -minimal -qt4"

livecd / # gcc-config -l
[1] i686-pc-linux-gnu-5.4.0

I've chancged gcc to 4.9.4 but not achieved nothing.

Here https://www.gentoo.org/support/news-items/2014-06-15-gcc48_ssp.html GCC 4.8.3 defaults to -fstack-protector. How to fix?

1 Answer 1

0

this will work:

genkernel --menuconfig all

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .