1

I am trying to install KUTE traffic generator on Fedora Core 5 kernel version 2.6.15.

When I try to complile I get this error message:

[root@dhcppc128 kute-1.4]# make
make modules
make[1]: Entering directory `/kute-1.4'
make -C /lib/modules/2.6.15-1.2054_FC5smp/build SUBDIRS=/kute-1.4 modules
make: *** /lib/modules/2.6.15-1.2054_FC5smp/build: No such file or directory. Stop.
make: Entering an unknown directorymake: Leaving an unknown directorymake[1]: *** [modules] Error 2
make[1]: Leaving directory `/kute-1.4'
make: *** [all] Error 2

Also I get errors when trying to patch.

I have been told I need to install the kernel headers, and I have tried installing the kernel headers and kernel devel from the DVD:

I have checked the kernel version and it is: 2.6.15-1.2054_FCSsmp i686

I have tried the kernel-smp-devel.2.6.15-1.2054_FC5.i686 RPM but it gives an error message.

rpm -i kernel-smp-devel-2.6.15-1.2054_FC5.i686.rpm
warning: kernel-smp-devel-2.6.15-1.2054_FC5.i686.rpm: Header V3 DSA signature: NOKEY, key ID 4f2a6fd2
error: Failed dependencies:
/usr/sbin/hardlink is needed by kernel-smp-devel-2.6.15-1.2054_FC5.i686

Installing the kernel-devel.2.6.15-1.2054_FC5.i686 RPM does work but I still get the same problem with compiling, even after a reboot.

I am guessing I need to install the SMP version?

P.S. I am running it on a P4 3.0 Ghz with 1 Gig RAM.

2

Fedora Core 5 is prehistoric, on its kernel you won't ever be able to build new modules. The in-kernel API is far from static.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.