0

I have a bananapi pro and run armbian on it. I tried stable, testing and experimental (in that order) all with the same result. When I try

cryptsetup luksOpen /dev/sda1 ext_crypt

I get

Enter passphrase for /dev/sda1: 
device-mapper: reload ioctl on  failed: No such file or directory
Failed to setup dm-crypt key mapping for device /dev/sda1.
Check that kernel supports aes-xts-plain64 cipher (check syslog for more info).

syslog:

May  4 20:53:19 localhost kernel: [78739.635960] device-mapper: table:
254:0: crypt: Error allocating crypto tfm May  4 20:53:19 localhost
kernel: [78739.635973] device-mapper: ioctl: error adding target to
table

I may want to add: The device in question (/dev/sda1) was luks formated and used on a bananapi (plain, not pro) before.

Do I have to compile my own kernel? Why is it, that I cannot open this device?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.