5

I'm trying to mount my NTFS partition. When I try $sudo mount /dev/sda8 /media/FILES I get something like this fuse: device not found, try 'modprobe fuse' first. Then I of course tried this $modprobe fuse and I got modprobe: FATAL: Module fuse not found in directory /lib/modules/4.9.25. I also tried $ntfsfix and ntfs-3g commands... Earlier I didn't have this fuse and I was successfully mounting. Could you help me with this issue?

UPD: linux 4.10.13-1 and kernel 4.9.25

UPDATE 12.05.17 All in all, I tried to find a Fuse module in kernel and rebuild it. And yes! I forgot to mark fuse. After recompiling kernel and rebooting it successfully works with mount /dev/sda8 /media. Thanks you all

  • Actually I guess earlier when I hadn't ntfs-3g and another stuff it worked fine. So do I need recompile kernel with this fuse support? – Dmytro Osaulenko May 7 '17 at 20:09
  • Exactly, read-write. Ok, thanks, I will recompile kernel – Dmytro Osaulenko May 7 '17 at 20:26
  • 1
    You don't need to recompile the kernel if you are using the standard Arch one. Please edit your question with the output of pacman -Q linux && uname -r. – jasonwryan May 7 '17 at 21:00
  • I updated the question – Dmytro Osaulenko May 7 '17 at 21:34
9

Your issue is that you haven't rebooted since upgrading your kernel, so you cannot load any of the kernel modules you require.

| improve this answer | |
2

Always check the Arch documentation because it is usually the most updated source: https://wiki.archlinux.org/index.php/NTFS
As you can see it points you to the ntfs-3g package

So the first step to have a full ntfs support on linux is to have the above package installed. As root, simply install with:

pacman -Syu 
pacman -S ntfs-3g

After that you are ready to create/mount/read/write ntfs partitions.

Details:

pacman will take care of the dependencies (including fuse2). You don't need to recompile the kernel.

Once you installed ntfs-3g simply using the mount command should work. You could also use your file manager (Nautilus in Gnome or Dolphin in KDE, for ex., both support it and you don't need to manually mount anything)

I'm assuming it's an internal harddrive and not an usb drive due to the naming (sda), so if you want it mounted at system boot, you may want to put it in the /etc/fstab:

# <file system>   <dir>     <type>    <options>             <dump>  <pass>
/dev/NTFS-part  /mnt/win  ntfs-3g   defaults          0       0

Where according to your question, NTFS-part should be /dev/sda8, but please verify this.

Also, if you wish to write you might want to set the default recommended options:

# <file system>   <dir>     <type>    <options>             <dump>  <pass>
/dev/NTFS-part  /mnt/win  ntfs-3g   uid=username,gid=users,umask=0022    0       0

Here you should replace username in the uid field with yours. The umask setting should take care of the permissions compatibility between NTFS and Linux. The gid allows the members of the users group access (and mount). By default in Arch Linux every user is member of the users group. Check it with the groups command to see your membership.

There are a few other settings to take into account, but I will refer you to the official Arch Linux NTFS wiki for those.

Edit: added y to pacman flags, to make sure the DB is up to date before installing the package.

Edit 2: added u to pacman flag just in case someone already has the package installed and by chance there is an upgrade for that specific package and also dependencies that would break the system according to the comment made below. The downvote is a bit extreme considering the question/answer conditions of a new install.

Edit 3: Separated the update/upgrade from the install, just to be clear.

| improve this answer | |
  • 1
    Never run -Sy $package: it breaks things... – jasonwryan May 7 '17 at 20:59
  • @jasonwryan I understand your concern, but you are mixing things. You shouldn't update single packages. We are installing a new one here. But, just so in case someone already has the package and not to screw their system I will update my answer with -Syu (which will update the whole system before installing, just in case), although I don't recommend doing it either without first checking the Arch homepage and forums. PS: Downvoting on that single issue is way rude. – Leo May 8 '17 at 20:30
  • No, you don't understand how pacman works. It doesn't matter whether the package is new or not, -Sy is always a potential partial upgrade. – jasonwryan May 8 '17 at 20:35
  • 1
    I have been using Arch Linux since 2003, I do understand. That's why I corrected my command as per your comment. I share your view, but don't think it was as bad as to downvote instead of waiting for the edit or simply correcting the command to "-Syu". Thanks for being rude instead of helpful. – Leo May 8 '17 at 20:44
  • this answer is correct. ntfs-3g is required to create/write ntfs partition. if you just need to read ntfs partition I think the kernel already allows this without the ntfs-3g package – Francesco May 1 '18 at 5:57
1

All in all, I tried to find a Fuse module in kernel config and rebuild it. And yes! I forgot to mark fuse. After recompiling kernel and rebooting it successfully works with mount /dev/sda8 /media.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.