3

I'm trying to debootstrap from local files. I followed this guide.

My host machine runs debian that I installed with :

debootstrap stable /mnt http://httpredir.debian.org/debian/

What I did:

mkdir /opt/.../mymirror

apt-get install apt-move

# nano /etc/apt-move.conf
LOCALDIR=/opt/.../mymirror
DIST=stable
COPYONLY=yes

apt-move update

debootstrap stable /var/new-env file:///opt/.../mymirror

Debootstrap fails with: E: Invalid Release file, no entry for main/binary-amd64/Packages. I also had to add the flag --no-check-gpg because it seems that apt-move doesn't provide the signatures. I'd love to know how to add them manually.

However, there is an entry for main/binary-amd64/Packages, but it doesn't exist. There is a gzip version, for which there is also an entry. I tried unzipping it, but it didn't help.

How can I fix this? Should I maybe use apt-mirror instead? Thanks for any hints!

ATTACHMENT:

Contents of /opt/.../mymirror/dists/stable/main/binary-amd64/

Packages.gz Release

File /opt/.../mymirror/dists/stable/Release:

Origin: APT-Move
Label: APT-Move
Suite: stable
Codename: unknown
Date: Sat, 06 May 2017 21:08:02 UTC
Architectures: amd64
Components: main
Description: unknown
MD5Sum:
 f5244c43783c0f17f2a4b5752b65f11d            17492 main/binary-amd64/Packages
 45d99ca4f61995544e66b8506326faac             5068 main/binary-amd64/Packages.gz
 ec21618e5a563d265fc97194326b1f47               85 main/binary-amd64/Release
SHA1:
 9a167984013d21a037e5f34d032575847827e61d            17492 main/binary-amd64/Packages
 4908eb9d8ab8084e4846d908629617ecca8cdebd             5068 main/binary-amd64/Packages.gz
 06653674d2e79dd39dbbf77544795b2f425ddf0d               85 main/binary-amd64/Release

File /opt/.../mymirror/dists/stable/main/binary-amd64/Release

Archive: stable
Component: main
Origin: APT-Move
Label: APT-Move
Architecture: amd64
  • @GAD3R Thank you, but I don't have a directory 'debian' in the local repo. In the top directory of the repo there is dists and pool. Do you mean: dists/stable/main/binary-amd64/ ? – rudib May 6 '17 at 23:07
  • @GAD3R I've tried a few versions of this, but it didn't work. dpkg-scanpackages says: Wrote 0 entries to output Packages file. – rudib May 6 '17 at 23:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.