1

I am trying to get Wifi working on my Arch Linux installation so I have installed broadcom-wl-dkms, but it still does not seem to work. I noticed that one every startup I got this message:

Support for cores revisions 0x17 and 0x18 disabled by module param allhwsupport=0. Try b43.allhwsupport=1

So I enabled them as it said, but still the Wifi doesn't work.

During the broadcom-wl-dkms installation I was told to run the following commands or reboot (neither worked):

rmmod b43 b43legacy ssb bcm43xx brcm80211 brcmfmac brcmsmac bcma wl
modprobe wl

Upon running the first one I got this output:

rmmod: ERROR: Module b43legacy is not currently loaded
rmmod: ERROR: Module bcm43xx is not currently loaded
rmmod: ERROR: Module brcm80211 is not currently loaded
rmmod: ERROR: Module brcmfmac is not currently loaded
rmmod: ERROR: Module wl is not currently loaded

And the second gave this output:

modprobe: FATAL: Module wl not found in directory /lib/modules/4.11.0-1-hardened

I have also noticed that on Kernel updates I get messages like this:

==> dkms remove broadcom-wl/6.30.223.271 -k 4.11.0-1-hardened
Error! There is no instance of broadcom-wl 6.30.223.271
for kernel 4.11.0-1-hardened (x86_64) located in the DKMS tree.

And this:

==> dkms install broadcom-wl/6.30.223.271 -k 4.11.0-2-hardened
Error! Bad return status for module build on kernel: 4.11.0-2-hardened (x86_64)
Consult /var/lib/dkms/broadcom-wl/6.30.223.271/build/make.log for more information.

So I assume that something has gone wrong. What has gone wrong? And how can I fix this and get the Wifi working?

This is a Lenovo B590 laptop.

  • What is the output of dmesg | grep b43? If you don't have a device with core revision 0x17 or 0x18, there is no reason to enable those revisions – Fox May 6 '17 at 18:19
  • @Fox: I have updated my question with the information you requested. – user103789 May 6 '17 at 18:31
  • Have you tried the broadcom-wl driver instead? (It seems to be newer and better supported, and from the contents you show, it looks like you might have one of those two disabled revisions) – Fox May 6 '17 at 18:35
  • @Fox: No, but I have been trying to have a go with broadcom-wl-dkms as I generally don't trust things in the AUR. – user103789 May 6 '17 at 18:47
  • But that doesn't seem to be going very well as it hasn't made any real difference other than the Wireless section has disappeared from the gnome-control-center. – user103789 May 6 '17 at 18:50
2

OP has a Broadcom BCM4313 chipset, which is not supported by the b43 driver, so enabling the core revisions listed in the warning will have no effect. Further, this particular chipset is not fully supported by the brcmsmac driver, leaving only Broadcom's own (restrictively-licensed) broadcom-wl driver, specifically the broadcom-wl-dkms variant.

However, at the time the Q was posted, the broadcom-wl driver (at least in the Arch repositories) was not yet updated to support kernels 4.11-rc1 or later. These newer kernels changed a bit of the interface to network devices, including removing the last_rx field from struct net_device.

As of 10 May 2017, version 6.30.223.271-12 of the broadcom-wl-dkms driver was made available through these repositories, allowing compilation against the 4.11 series kernels.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy