1

This question already has an answer here:

I am running 64-bit Debian testing. When I try to run steam I get the following error:

Package libgl1-mesa-dri:i386 needs to be installed
Package libgl1-mesa-glx:i386 needs to be installed
Package libc6:i386 needs to be installed

I am however, unable to apt-get the desired mesa driver:

$ sudo apt-get install libgl1-mesa-dri:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package libgl1-mesa-dri:i386

marked as duplicate by Stephen Kitt debian May 6 '17 at 14:48

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2

You have to enable the i386 architecture first

$ sudo dpkg --add-architecture i386 && sudo apt-get update

Then you should be able to install the desired packages

Not the answer you're looking for? Browse other questions tagged or ask your own question.