3

When I print in Plasma applications, such as Gwenview, I can select Grayscale instead of Color (see screenshot below). However, this doesn't do anything; images are always printed in colour. In contrast, I can print in greyscale in Firefox and Inkscape by selecting Print Color as Gray = On using their native print dialogue (perhaps GTK?). Hence, I presume that there is an issue specific to the KDE Plasma print dialogue box. Is there a way to print in greyscale in Gwenview?

Gwenview print dialogue

(Originally posted here with no answer.)

  • I can print in greyscale in Firefox ... by selecting Print Color as Gray = On using their native print dialogue (perhaps GTK?) - Where is that color option in the Firefox printing options? I only see this and this. – cipricus Jun 21 at 16:01
0

EDIT: Sorrily, I see after more testing that while the below settings (adding CNGrayscale) can do the job, the solution is not too convenient because the change is not remembered... It can still be used as a last resort...


I have tested this in Xfce, not in KDE. Initially posted here.

In System - Printers, selecting the printer's properties, going to "Job options" - "Other options", down at the end there is an empty field to add a new option; fill that field with CNGrayscale and click "Add".

The new option is now listed under "Other options", but has an empty field: fill that with TRUE, then click "Apply".

enter image description here

Now the new option CNGrayscale has a true/false switch that you can use to change between color and monochrome printing.


This seems to be related to availability or correct selection of drivers. Printers connect in different ways, and drivers can be selected automatically or manually. A solution might be to try adding the printer manually in a way that gives choice between different drivers that can be in this way tested.

For example, in my case, I was able to add the proper driver by connecting my wifi HP Officejet 3833 printer by USB cable to my internet modem/wifi box then, following this method that is specific to my internet provider I have added new printer, selected Network printer > AppSocket/HP JetDirect, then entered my provider-specific data under Location of the network printer - Host:, then, selecting a driver from the database, I have selected HP; all Officejet numbers 3830 to 3834 had the same 3 drivers available:

enter image description here

The first in the list, which is marked 'recommended' was the one selected the last time and which entailed the very problem I was trying to solve. So, I have now selected the second one, the one that says 'hpcups' (the printer being HP).

The third is hpijs; these two drivers come from HP and are based on hplip, as said here, but when testing both I see differences in the printer properties' interfaces: the hpijs driver doesn't have a color settings under "Printer options", and changes of the one under "Jop Options - Other options (Advanced)" are not remembered. So, hpcups is the good one for me.

In this way I have added the printer which, under Properties > Printer options > Color mode, now shows, beside Color, another two Grayscale options (High quality and Black only).

So, this seems a driver issue.

3.17 version worked for me, but there is also a newer version of the driver that can be installed like in the askubuntu answer here, redirecting to the HP page here.

  • Thank you for posting! In KDE I can find a similar looking pane via Print Settings > Right-click on the printer > Properties > Job Options. However, after following the instructions as shown in this screenshot, it's still printing in colour. I tried restarting the systemd units org.cups.cupsd.service and cups-browsed.service, but that didn't help. Also, do you have to open this dialog every time you want to toggle it back? I didn't find any option in the normal print dialog. – Sparhawk Jun 19 at 10:31
  • I guess I was lucky. See more links on various solutions at the address that pointed the way for me here. – cipricus Jun 19 at 13:08
  • Thanks for the links. I had a read through, but there wasn't much else that was relevant, I don't think, because I can print in greyscale in some situations, e.g. Firefox, but just not from KDE applications. So I don't think it's a general printing issue. I don't seem to have anything called "Color mode" in "Printer Options", as per this screenshot – Sparhawk Jun 19 at 23:17
  • I suspect you might be right regarding the driver-specific settings. (FWIW I only have one copy.) – Sparhawk Jun 20 at 9:31
  • @Sparhawk - I don't think it's a general printing issue - it still could be a driver problem, involving only those applications that, unlike Firefox, rely on the settings in the printer-driver-GUI. – cipricus Jun 21 at 15:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.