1

I am trying to compile and boot Linux Kernel v3.19 (64-bit version) using -

    make defconfig
    make kvmconfig
    make -j8
The compilation works out without any errors but it doesn't boot inside qemu or my host machine. I use the following command line parameters to linux: "debug earlyprintk loglevel=7"

The boot hangs at the point -

Booting from ROM...
early console in setup code
early console in decompress_kernel

Decompressing Linux... Parking ELF... done.
Booting the kernel .

Things I have tried so far -

  • Interestingly if I uncheck the 64-bit build in config (from make menuconfig), the resulting 32-bit kernel boots correctly.
  • Have tried running qemu with different cpus (host) + with & without kvm.
    sudo qemu-system-x86_64 -m 4G -append 'debug earlyprintk loglevel=7' -kernel arch/x86/boot/bzImage -cpu host -enable-kvm

I know the kernel will panic because of no root filesystem, but it happens later in the boot process. I am basing this from booting the 32 bit version of the kernel which prints out a lot of stuff and then panics due to no vfs_root.

  • The 64-bit versions of kernel v4.2 and above don't have this issue - meaning they boot correctly.

Any pointers to what the mistake is?

Linux Kernel Repo used: git://git.kernel.org/pub/scm/linux/kernel/git/stable/linux-stable.git

My Config: https://dl.dropboxusercontent.com/u/9020146/errors/linux_2017_05_05/config-used

QEMU version: QEMU emulator version 2.5.0 (Debian 1:2.5+dfsg-5ubuntu10.11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.