3

I need to install libgdiplus on CentOS 7. The application which I am running needs this package.

I was able to install it on Ubuntu, by using following command:

sudo apt-get install libgdiplus

But when I run following command on CentOS, it says package not found.

sudo yum install libgdiplus
6

You can search such packages using:

  • yum whatprovides libgdiplus

The output shows: libgdiplus-2.10-9.el7.x86_64 : An Open Source implementation of the GDI+ API.

Then, you can run: yum install -y libgdiplus-2.10-9.el7.x86_64

As @Knud Larsen mentioned; you need to install EPEL packages repository previously. To do so, you can run:

yum install -y epel-release

1

libgdiplus and libgdiplus-devel : Both are in the most commonly used extra repo for EL7 : epel.repo → "Extra Packages for Enterprise Linux"

https://fedoraproject.org/wiki/EPEL → → https://fedoraproject.org/wiki/EPEL/FAQ#How_can_I_install_the_packages_from_the_EPEL_software_repository.3F

su -c 'rpm -Uvh http://download.fedoraproject.org/pub/epel/7/x86_64/e/epel-release-7-8.noarch.rpm'
1
  • 1
    IIRC Centos now ships with the initial Meta-RPM for EPEL, so sudo yum install epel-release should do it. – Ulrich Schwarz May 4 '17 at 11:03
-1
sudo yum install mono-complete -y

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.