I have a remote VM to which I connect using SSH. Now i need to install Tomcat 8 for which I run wget command

wget http://mirror.fibergrid.in/apache/tomcat/tomcat-8/v8.5.14/bin/apache-tomcat-8.5.14.zip

But this gives me following error every time:

Connecting to mirror.fibergrid.in 
(mirror.fibergrid.in)||:80... connected.
HTTP request sent, awaiting response... Read error (Connection reset by 
peer) in headers.

I also have tried yum command but I don't have root access.

1 Answer 1


Something like Tomcat whilst it can be installed from source, is best installed by packages and on the plus side, it can be configured to start automatically.

It is also not guaranteed you will have all the dependencies installed, like Java JDK and the Java libraries.

The link is also working ok, it is firewall rules or communication problems on your side. By the error, "Connection reset", it seems you have firewall rules/a firewall preventing you from downloading the file.

I strongly advise either getting root access or talking with your resident sysadmin.

Update after OPs comments: Indeed, having used sudo to install openJDK, it means you have root access.

I would then install tomcat8 from CentOS repositories with yum; as I do not have access to CentOS, I am not sure whether a sudo yum install tomcat is installing the latest version.

Please see How to install Apache Tomcat 8 on centos 7?

  • I was able to install Open-JDK 1.8 by sudo yum. Does that mean I have root access?
    – roger_that
    May 4, 2017 at 9:25
  • Added answer to that. May 4, 2017 at 9:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .