2

I've recently installed Linux Mint 18.1 and I'm very new to it. Everything is fine with wifi, but I cannot access the internet via ethernet cable. When I try to connect, Chromium just says that there is no internet connection.

Output of sudo ifconfig -a:

enp5s0    Link encap:Ethernet  HWaddr 1c:75:08:26:90:db  
      inet addr:192.168.0.100  Bcast:192.168.0.255  Mask:255.255.255.0
      inet6 addr: fe80::1e75:8ff:fe26:90db/64 Scope:Link
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:7381 errors:0 dropped:0 overruns:0 frame:0
      TX packets:7203 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:1278143 (1.2 MB)  TX bytes:789190 (789.1 KB)
      Interrupt:18 
lo        Link encap:Local Loopback  
      inet addr:127.0.0.1  Mask:255.0.0.0
      inet6 addr: ::1/128 Scope:Host
      UP LOOPBACK RUNNING  MTU:65536  Metric:1
      RX packets:2 errors:0 dropped:0 overruns:0 frame:0
      TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1 
      RX bytes:98 (98.0 B)  TX bytes:98 (98.0 B)
wlp4s0    Link encap:Ethernet  HWaddr 00:26:c6:da:7e:30  
      UP BROADCAST MULTICAST  MTU:1500  Metric:1
      RX packets:0 errors:0 dropped:0 overruns:0 frame:0
      TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

output of iwconfig:

lo        no wireless extensions.

enp5s0    no wireless extensions.

wlp4s0    IEEE 802.11abgn  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=15 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off

Relevant output of lspci:

04:00.0 Network controller: Intel Corporation WiFi Link 5100
05:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5764M Gigabit Ethernet PCIe (rev 10)

I tried adding the following lines to /etc/network/interfaces:

auto enp5s0
iface enp5s0 inet dhcp

but it doesn't work. I still can't connect to the internet.

Output of dmesg | tail -n 20 after plugging in the network cable:

[   41.903417] ACPI Warning: \_SB_.PCI0.PEGP.VGA_._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20150930/nsarguments-95)
[   41.903485] ACPI Warning: \_SB_.PCI0.PEGP.VGA_._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20150930/nsarguments-95)
[   41.903552] ACPI Warning: \_SB_.PCI0.PEGP.VGA_._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20150930/nsarguments-95)
[   41.904761] ACPI Warning: \_SB_.PCI0.PEGP.VGA_._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20150930/nsarguments-95)
[   42.023873] iwlwifi 0000:04:00.0: RF_KILL bit toggled to enable radio.
[   42.025694] iwlwifi 0000:04:00.0: L1 Enabled - LTR Disabled
[   42.033148] iwlwifi 0000:04:00.0: L1 Enabled - LTR Disabled
[   42.033265] iwlwifi 0000:04:00.0: Radio type=0x1-0x2-0x0
[   43.350521] iwlwifi 0000:04:00.0: L1 Enabled - LTR Disabled
[   43.354652] iwlwifi 0000:04:00.0: L1 Enabled - LTR Disabled
[   43.354750] iwlwifi 0000:04:00.0: Radio type=0x1-0x2-0x0
[   43.395109] IPv6: ADDRCONF(NETDEV_UP): wlp4s0: link is not ready
[   43.489583] IPv6: ADDRCONF(NETDEV_UP): wlp4s0: link is not ready
[ 2299.040250] CE: hpet increased min_delta_ns to 20115 nsec
[ 4705.704005] tg3 0000:05:00.0 enp5s0: Link is down
[ 4713.523072] tg3 0000:05:00.0 enp5s0: Link is up at 1000 Mbps, full duplex
[ 4713.523093] tg3 0000:05:00.0 enp5s0: Flow control is off for TX and off for RX
[ 4779.820050] tg3 0000:05:00.0 enp5s0: Link is down
[ 4786.441835] tg3 0000:05:00.0 enp5s0: Link is up at 1000 Mbps, full duplex
[ 4786.441856] tg3 0000:05:00.0 enp5s0: Flow control is off for TX and off for RX

output of ping -c2 8.8.8.8

PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.

--- 8.8.8.8 ping statistics ---
2 packets transmitted, 0 received, 100% packet loss, time 1007ms

EDIT

output of sudo iptables -vL

Chain INPUT (policy ACCEPT 0 packets, 0 bytes)
 pkts bytes target     prot opt in     out     source               destination         

Chain FORWARD (policy ACCEPT 0 packets, 0 bytes)
 pkts bytes target     prot opt in     out     source               destination         

Chain OUTPUT (policy ACCEPT 0 packets, 0 bytes)
 pkts bytes target     prot opt in     out     source               destination 

ONE MORE EDIT

output from ipconfig on Windows (it's russian language, sorry)

Настройка протокола IP для Windows

Адаптер PPP Internet:

   DNS-суффикс подключения . . . . . :
   IPv4-адрес. . . . . . . . . . . . : 192.168.57.121
   Маска подсети . . . . . . . . . . : 255.255.255.255
   Основной шлюз. . . . . . . . . : 0.0.0.0

Ethernet adapter Tunngle:

   Состояние среды. . . . . . . . : Среда передачи недоступна.
   DNS-суффикс подключения . . . . . :

Ethernet adapter Подключение по локальной сети 2:

   DNS-суффикс подключения . . . . . :
   Локальный IPv6-адрес канала . . . : fe80::d5fe:d1a2:2e54:eeeb%16
   Автонастройка IPv4-адреса . . . . : 169.254.238.235
   Маска подсети . . . . . . . . . . : 255.255.0.0
   Основной шлюз. . . . . . . . . :

Адаптер беспроводной локальной сети Беспроводное сетевое соединение 2:

   Состояние среды. . . . . . . . : Среда передачи недоступна.
   DNS-суффикс подключения . . . . . :

Туннельный адаптер isatap.{7B8FAF91-9786-4E2C-A66F-3387471FD72B}:

   Состояние среды. . . . . . . . : Среда передачи недоступна.
   DNS-суффикс подключения . . . . . :

Туннельный адаптер isatap.{FD3701FE-07FF-4726-ACD9-38B926C34CF5}:

   Состояние среды. . . . . . . . : Среда передачи недоступна.
   DNS-суффикс подключения . . . . . :
  • Do you have a default route (ip route ls | grep default)? If so, can you ping the "via" IP address? – derobert May 3 '17 at 17:48
  • @derobert default via 192.168.0.1 dev enp5s0 – Mike Herasimov May 3 '17 at 17:50
  • @derobert --- 192.168.0.1 ping statistics --- 2 packets transmitted, 0 received, 100% packet loss, time 1008ms it's network of my home – Mike Herasimov May 3 '17 at 17:54
  • You wouldn't happen to have any firewall rules on this machine that could be blocking the connection? E.g., iptables -vL to check for firewall rules. Also, are there any other wired machines on the network? Do they work? – derobert May 3 '17 at 17:55
  • @derobert modprobe: ERROR: could not insert 'ip_tables': Operation not permitted iptables v1.6.0: can't initialize iptables table filter': Table does not exist (do you need to insmod?) Perhaps iptables or your kernel needs to be upgraded.` – Mike Herasimov May 3 '17 at 17:57
4

It turns out you need to run PPPoE to connect to the Internet. The easiest way to do that is to run pppoeconf and follow the prompts.

If instead you want to instead configure it by hand, it'd be something like this (taken from a working config I have):


/etc/network/interfaces

auto enp5s0-ppp
iface enp5s0-ppp inet ppp
        pre-up ip link set enp5s0 up mtu 1508 # if your ISP supports
        provider your-isp


/etc/ppp/pap-secrets

Obviously, use your actual ISP-provided username and password instead of the placeholders here. The * specifies which remote this applies to, easiest to use * if you've only got one remote.

"your-username" * "your-password"


/etc/ppp/peers/your-isp

Note this one is a little different than my file—my config has static IP addresses, so there is a local-ip: line instead of noipdefault.

noipdefault
noauth
persist
maxfail 0

mtu 1500
mru 1500

noktune
defaultroute

ifname enp5s0-ppp

noaccomp 
default-asyncmap

plugin rp-pppoe.so enp5s0
user "your-username"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.