1

So Dolphin is behaving funny. I can't tell you if this is new or not.

System Info: Arch Linux 64 bit up to date, standalone startx with i3. The devices in question are fat32 and exfat (stupid windows support...). I haven't tried formatting them to ext4 because that just isn't an option for me.

1) Open Dolphin, instert USB, device recognized! 2) Insert USB, open Dolphin, device not listed :(

I can run a mount /dev/sdc1 /mount/xxx no problem.

fdisk -l out:

Disk /dev/sda: 223.6 GiB, 240057409536 bytes, 468862128 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 6EEBD8E6-6C6B-415F-8DF2-5E635871C1E1

Device         Start       End   Sectors   Size Type
/dev/sda1       2048    976895    974848   476M EFI System
/dev/sda2     976896  59570175  58593280    28G Linux filesystem
/dev/sda3   59570176 387002367 327432192 156.1G Linux filesystem
/dev/sda4  387002368 468860927  81858560    39G Microsoft basic data


Disk /dev/sdb: 465.8 GiB, 500107862016 bytes, 976773168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: dos
Disk identifier: 0xcf4dbac4

Device     Boot     Start       End   Sectors   Size Id Type
/dev/sdb1  *         2048    206847    204800   100M  7 HPFS/NTFS/exFAT
/dev/sdb2          206848 738678783 738471936 352.1G  7 HPFS/NTFS/exFAT
/dev/sdb3       738678784 972658687 233979904 111.6G 83 Linux
/dev/sdb4       972658688 976773167   4114480     2G 82 Linux swap / Solaris


Disk /dev/sdc: 7.5 GiB, 8029470208 bytes, 15682559 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x56604413

Device     Boot Start      End  Sectors  Size Id Type
/dev/sdc1        2048 15681535 15679488  7.5G  b W95 FAT32

Dolphin recognized all of the partitions on my SSD and HDD, it is just USBs that are the problem. Any ideas?

Thanks!

0

If you're on a laptop, try rebooting. The reason for this is when your laptop is running on really low battery, it starts to suspend peripheral services to reduce power.

You can detect if this is happening by typing the following into the terminal:

cat /sys/module/usbcore/parameters/autosuspend

If this returns 2, that means your autosuspend is enabled.


To disable this feature, edit your /etc/default/grub file. Look for the following line:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

and change to

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash usbcore.autosuspend=-1"

Then run sudo update-grub (note: this may take a while).

Good luck!

source: https://www.makeuseof.com/tag/fix-usb-device-port-linux/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.