2

I'm trying to do a Mono install package per package, because the CentOS server doesn't have internet access. However, when I try to install the mono core package using the command:

rpm -i mono-core-4.8.1.0-0.xamarin.1.x86_64.rpm

The system displays the following error message:

error: Failed dependencies:
    mono(System.ComponentModel.Composition) = 4.0.0.0 is needed by mono-core-4.8.1.0-0.xamarin.1.x86_64
    mono(System.ComponentModel.DataAnnotations) = 4.0.0.0 is needed by mono-core-4.8.1.0-0.xamarin.1.x86_64
    mono(System.Data) = 4.0.0.0 is needed by mono-core-4.8.1.0-0.xamarin.1.x86_64
    mono(System.IdentityModel) = 4.0.0.0 is needed by mono-core-4.8.1.0-0.xamarin.1.x86_64
    mono(System.Runtime.Serialization) = 4.0.0.0 is needed by mono-core-4.8.1.0-0.xamarin.1.x86_64
    mono(System.ServiceModel) = 4.0.0.0 is needed by mono-core-4.8.1.0-0.xamarin.1.x86_64
    mono(System.ServiceProcess) = 4.0.0.0 is needed by mono-core-4.8.1.0-0.xamarin.1.x86_64

How do I solve these dependencies?

UPDATE

I'm trying to use this command:

yum localinstall mono-core-4.8.1.0-0.xamarin.1.x86_64.rpm

Result:

Examining mono-core-4.8.1.0-0.xamarin.1.x86_64.rpm: mono-core-4.8.1.0-0.xamarin.1.x86_64
Marking mono-core-4.8.1.0-0.xamarin.1.x86_64.rpm to be installed
Resolving Dependencies
   Running transaction check
   Package mono-core.x86_64 0:4.8.1.0-0.xamarin.1 will be installed
   Processing Dependency: mono(System.ComponentModel.Composition) = 4.0.0.0 for package: mono-core-4.8.1.0-0.xamarin.1.x86_64                                                                                                                        
   Processing Dependency: mono(System.ComponentModel.DataAnnotations) = 4.0.0.0 for package: mono-core-4.8.1.0-0.xamarin.1.x86_64                                                                                                                                                       
   Processing Dependency: mono(System.Data) = 4.0.0.0 for package: mono-core-4.                                                                                                                                                           
   Processing Dependency: mono(System.IdentityModel) = 4.0.0.0 for package: mono-core-4.8.1.0-0.xamarin.1.x86_64  
   Processing Dependency: mono(System.Runtime.Serialization) = 4.0.0.0 for package: mono-core-4.8.1.0-0.xamarin.1.x86_64                                                                                                                                                             
   Processing Dependency: mono(System.ServiceModel) = 4.0.0.0 for package: mono-core-4.8.1.0-0.xamarin.1.x86_64                                                                                                                                                            
   Processing Dependency: mono(System.ServiceProcess) = 4.0.0.0 for package: mono-core-4.8.1.0-0.xamarin.1.x86_64                                                                                                                                                             
  Finished Dependency Resolution
Error: Package: mono-core-4.8.1.0-0.xamarin.1.x86_64 (/mono-core-4.8.1.0-0.xamarin.1.x86_64) Requires: mono(System.Data) = 4.0.0.0                                                                                                                                                            
Error: Package: mono-core-4.8.1.0-0.xamarin.1.x86_64 (/mono-core-4.8.1.0-0.xamarin.1.x86_64) Requires: mono(System.ComponentModel.DataAnnotations) = 4.0.0.0                                                                                                                                                             
Error: Package: mono-core-4.8.1.0-0.xamarin.1.x86_64 (/mono-core-4.8.1.0-0.xamarin.1.x86_64) Requires: mono(System.IdentityModel) = 4.0.0.0                                                                                                                                                             
Error: Package: mono-core-4.8.1.0-0.xamarin.1.x86_64 (/mono-core-4.8.1.0-0.xamarin.1.x86_64) Requires: mono(System.ServiceModel) = 4.0.0.0                                                                                                                                                             
Error: Package: mono-core-4.8.1.0-0.xamarin.1.x86_64 (/mono-core-4.8.1.0-0.xamarin.1.x86_64) Requires: mono(System.ComponentModel.Composition) = 4.0.0.0                                                                                                                                                             
Error: Package: mono-core-4.8.1.0-0.xamarin.1.x86_64 (/mono-core-4.8.1.0-0.xamarin.1.x86_64) Requires: mono(System.Runtime.Serialization) = 4.0.0.0                                                                                                                                                             
Error: Package: mono-core-4.8.1.0-0.xamarin.1.x86_64 (/mono-core-4.8.1.0-0.xamarin.1.x86_64) Requires: mono(System.ServiceProcess) = 4.0.0.0

You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
1

Try yum localinstall mono-core-4.8.1.0-0.xamarin.1.x86_64.rpm and ideally yum will find and fetch the dependencies for you.

1

You could try using --skip-broken to work around the problem you can force to install the package but may have Dependencies issues later.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.