1

I want to turn off SACK and window scaling options in TCP in Ubuntu 16.04 running in a VMware virtual machine on windows 10. I am actually sending some packets through my Ubuntu to an embedded device which is connected directly through a LAN cable to my computer. No internet connection otherwise.

I have installed wireshark on both windows 10 and inside the ubuntu virtual machine to trace whether the SACK_PERM flag is gone (and window scaling is turned off) from the SYN packet after I add the following lines to /etc/sysctl.conf

net.ipv4.tcp_sack = 0
net.ipv4.tcp_window_scaling=0

as these two lines were missing from the said file.

Now the problem is, when I look at the SYN packets in wireshark on windows the SACK_PERM flag is present but on wireshark running inside ubuntu I don't see any such flag.

So, I have no idea whether whether turning off SACK is working or not. Any help regarding this issue will be appreciated.

2
  • I presume you've rebooted after setting these things? (sysctl isn't reloaded dynamically on a regular basis) Commented May 2, 2017 at 13:53
  • I have checked by restarting but the results are same. Do you think the TCP stack of windows is messing with the packets sent by the Ubuntu stack?
    – userXktape
    Commented May 2, 2017 at 14:01

1 Answer 1

0

TCP extension options SACKs, Timestamps, and Windows Scaling must be included in the SYN in both directions in order for either side to use the features for the connection.

If the Windows machine is sending the options in the SYN and the Ubuntu machine dos not send them in the SYN ACK, neither side will use the options for the connection.

3
  • No. this is not what I am doing. I have a ubuntu virtual machine running on my windows pc. From this VM I am sending tcp packets without SACK. This packet is sent to an embedded board connected with my PC through LAN. I think when my packet traverses through the VM , windows OS and the board , the windows TCP stack might be adding the SACK_PERM flag to it.
    – userXktape
    Commented May 3, 2017 at 12:46
  • Are you running the VM in NAT or Bridged mode?
    – Jeff S.
    Commented May 3, 2017 at 13:29
  • I am running in NAT mode and sharing the host's ip address.
    – userXktape
    Commented May 3, 2017 at 13:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .