0

I have repository repo-server - where all build rpm resides [cent os 5]. Continuum-SCM-build dumps all rpms here.

server 1 client server [cent os 5] -- get the required rpms from repo-server

server 2 delivery server [cent os 5]-- get the required rpms from repo-server

server 3 log server [cent os 5]-- get the required rpms from repo-server

server 4 brain server [cent os 5 and cent os 7]-- get the required rpms from repo-server

Here there are multiple servers with brains installed for different clients.

Till now all brains servers on cent os 5. Now I have new machine with cent os 7 on it and that is causing the issue. ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ Error message

./install.sh sh-j**n-server-2.1.3.1-8 <-- install script is using yum command to install Loaded plugins: fastestmirror Cleaning repos: base extras j***n updates Cleaning up everything Cleaning up list of fastest mirrors Loaded plugins: fastestmirror j***n | 951 B 00:00:00 j***n/primary
| 373 kB 00:00:00 Determining fastest mirrors j***n
2199/2199

Resolving Dependencies --> Running transaction check ---> Package sh-j***n-server.noarch 0:2.1.3.1-5 will be updated ---> Package sh-j***n-server.noarch 0:2.1.3.1-8 will be an update --> Processing Dependency: j***n = 2.1.3-6 for package: sh-j***n-server-2.1.3.1-8.noarch --> Running transaction check ---> Package j***n.noarch 0:2.1.3-3 will be updated ---> Package j***n.noarch 0:2.1.3-6 will be an update --> Finished Dependency Resolution

Dependencies Resolved

=============================================================================================================================================================================================

Package Arch Version Repository Size

Updating: sh-j***n-server noarch 2.1.3.1-8 j***n 8.2 k Updating for dependencies: j***n noarch 2.1.3-6 j***n 3.2 M

Transaction Summary

Upgrade 1 Package (+1 Dependent package)

Total download size: 3.2 M Is this ok [y/d/N]: y Downloading packages: No Presto metadata available for j***n (1/2): sh-j***n-server-2.1.3.1-8.noarch.rpm | 8.2 kB 00:00:00

(2/2): j***n-2.1.3-6.noarch.rpm | 3.2 MB 00:00:00

Total 4.0 MB/s | 3.2 MB 00:00:00 Running transaction check Running transaction test

Transaction check error: file /opt/shsolutions/scripts from install of j***n-2.1.3-6.noarch conflicts with file from package t***g-client-2.1.3-1.noarch file /opt/shsolutions/scripts from install of j***n-2.1.3-6.noarch conflicts with file from package cs-jb***t-listener-2.1.3-1.noarch file /opt/shsolutions/scripts from install of j***n-2.1.3-6.noarch conflicts with file from package ps-r***l-ws-2.1.3-1.noarch file /opt/shsolutions/webapps from install of j***n-2.1.3-6.noarch conflicts with file from package p**s-r***l-ws-2.1.3-1.noarch

  • Not clear to me but did you rebuild your RPM packages on CentOS 7? – fpmurphy May 1 '17 at 19:44
  • 1
    What commands did you run? What was the output of those commands? Sorry but it is really hard to help you given the information you have provided. Are you using "yum" or "rpm" command? Also your post title says CentOS 7, but your later say CentOS 5. Which is it? – Timothy Pulliam May 1 '17 at 19:54
  • No I haven't rebuild the RPM packages on Cent OS 7. – Utkarsh May 1 '17 at 20:53
  • I am using Yum Install [package name] command..! – Utkarsh May 1 '17 at 21:20
  • I have added extra notes to the question. Hope It helps see through clearly. Thank you. – Utkarsh May 1 '17 at 21:43
0

CentOS (and other Linux distributions) generally require you to rebuild your packages for each release. There is no guarantee that an RPM or set of RPMs that install correctly on CentOS 5 will install correctly on CentOS 7.

  • Thank you for your suggestion. I will try to rebuild in cent os 7 and see the outcome. – Utkarsh May 2 '17 at 13:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.